Kodi doesn't set the CAPATH and CAINFO parameters for libcurl. To make HTTPS connections work we can set them based on SSL_CERT_DIR and SSL_CERT_FILE. --- a/xbmc/filesystem/CurlFile.cpp +++ b/xbmc/filesystem/CurlFile.cpp @@ -626,5 +626,9 @@ if (!m_cipherlist.empty()) g_curlInterface.easy_setopt(h, CURLOPT_SSL_CIPHER_LIST, m_cipherlist.c_str()); + // Load certificate data from environment paths + g_curlInterface.easy_setopt(m_state->m_easyHandle, CURLOPT_CAPATH, getenv("SSL_CERT_DIR")); + g_curlInterface.easy_setopt(m_state->m_easyHandle, CURLOPT_CAINFO, getenv("SSL_CERT_FILE")); + // enable HTTP2 support. default: CURL_HTTP_VERSION_1_1. Curl >= 7.62.0 defaults to CURL_HTTP_VERSION_2TLS g_curlInterface.easy_setopt(h, CURLOPT_HTTP_VERSION, CURL_HTTP_VERSION_2_0); - } oszko-scripts Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gdb.scm
AgeCommit message (Expand)Author
2019-10-18gnu: rust: Use GDB 8.2 for tests....* gnu/packages/gdb.scm (gdb-8.2): New public variable. * gnu/packages/rust.scm (rust-1.27)[native-inputs]: Use GDB-8.2 instead of GDB. Marius Bakke
2019-10-12gnu: Remove GDB@8.2....* gnu/packages/gdb.scm (gdb-8.2): Rename to ... (gdb-8.3): ... this. Update to 8.3.1. (gdb): Refer to GDB-8.3. Marius Bakke
2019-09-23gnu: gdb-8.3: Update to 8.3.1....* gnu/packages/gdb.scm (gdb-8.3): Update to 8.3.1. Efraim Flashner
2019-05-13gnu: gdb: Add version 8.3....* gnu/packages/gdb.scm (gdb): Rename to... (gdb-8.2): ... this. (gdb-8.3): New variable. (gdb): Define as an alias for GDB-8.2. Ludovic Courtès
2019-02-10gnu: gdb: Update to 8.2.1....* gnu/packages/gdb.scm (gdb): Update to 8.2.1. Marius Bakke
2018-09-07gnu: gdb: Update to 8.2....* gnu/packages/gdb.scm (gdb): Update to 8.2. Ludovic Courtès
2018-08-24gnu: gdb: Update to 8.1.1....* gnu/packages/gdb.scm (gdb): Update to 8.1.1. Ludovic Courtès
2018-04-12gnu: gdb: Return #t from all phases....* gnu/packages/gdb.scm (gdb)[arguments]: Return #t from all phases. Mark H Weaver
2018-01-31gnu: gdb: Update to 8.1....* gnu/packages/gdb.scm (gdb): Update to 8.1. Ludovic Courtès