Increase thread timeout to reduce flakiness. Taken from upstream: https://github.com/xbmc/xbmc/commit/574b0182d8b641fd24029f372ebdcccc897123e2 diff --git a/xbmc/threads/test/TestEvent.cpp b/xbmc/threads/test/TestEvent.cpp index 42fb8c2fc609..40e644c0ed3c 100644 --- a/xbmc/threads/test/TestEvent.cpp +++ b/xbmc/threads/test/TestEvent.cpp @@ -484,7 +484,7 @@ TEST(TestEvent, GroupTimedWait) EXPECT_TRUE(w3.result == NULL); // this should end given the wait is for only 50 millis - EXPECT_TRUE(waitThread3.timed_join(MILLIS(100))); + EXPECT_TRUE(waitThread3.timed_join(MILLIS(200))); EXPECT_TRUE(!w3.waiting); EXPECT_TRUE(w3.result == NULL); a6d5'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/elf.scm
AgeCommit message (Expand)Author
2021-03-23gnu: libelf: Fix compilation for powerpc64le-linux....* gnu/packages/elf.scm (libelf)[arguments]: Modify replacement 'configure phase to invoke "./configure" with "--host=powerpc64le-unknown-linux-gnu" on powerpc64le-linux. Signed-off-by: Chris Marusich <cmmarusich@gmail.com> Leo Le Bouter
2021-01-25Merge branch 'master' into stagingLeo Famulari
2021-01-19gnu: libabigail: Update to 1.8....* gnu/packages/elf.scm (libabigail): Update to 1.8. Eric Bavier
2020-12-13gnu: elfutils: Update to 0.182....* gnu/packages/elf.scm (elfutils): Update to 0.182. [arguments]: Add "--disable-libdebuginfod" and "--disable-debuginfod" to #:configure-flags. Marius Bakke
2020-07-22gnu: patchelf: Update to 0.11....* gnu/packages/elf.scm (patchelf): Update to 0.11. Signed-off-by: Marius Bakke <marius@gnu.org> Michael Rohleder
2020-06-02gnu: libabigail: Update to 1.7....* gnu/packages/elf.scm (libabigail): Update to 1.7. Marius Bakke
2020-05-17gnu: elfutils: Skip tests on powerpc....* gnu/packages/elf.scm (elfutils)[arguments]: Skip tests on powerpc. Efraim Flashner