# Patch snarfed from # http://http.debian.net/debian/pool/main/k/kobodeluxe/kobodeluxe_0.5.1-8.debian.tar.xz # # Disable reading of configs, graphics, and data from the current directory. # So it's safe to run kobodeluxe from anywhere w/o worry about an attacker # feeding it bad data. --- kobodeluxe-0.5.1.orig/kobo.cpp +++ kobodeluxe-0.5.1/kobo.cpp @@ -141,21 +141,21 @@ * Graphics data */ /* Current dir; from within the build tree */ - fmap->addpath("GFX", "./data/gfx"); + //fmap->addpath("GFX", "./data/gfx"); /* Real data dir */ fmap->addpath("GFX", "DATA>>gfx"); /* Current dir */ - fmap->addpath("GFX", "./gfx"); + //fmap->addpath("GFX", "./gfx"); /* * Sound data */ /* Current dir; from within the build tree */ - fmap->addpath("SFX", "./data/sfx"); + //fmap->addpath("SFX", "./data/sfx"); /* Real data dir */ fmap->addpath("SFX", "DATA>>sfx"); /* Current dir */ - fmap->addpath("SFX", "./sfx"); + //fmap->addpath("SFX", "./sfx"); /* * Score files (user and global) @@ -173,7 +173,7 @@ /* System local */ fmap->addpath("CONFIG", SYSCONF_DIR); /* In current dir (last resort) */ - fmap->addpath("CONFIG", "./"); + //fmap->addpath("CONFIG", "./"); } 92b489c4b4'>refslogtreecommitdiff
path: root/gnu/services/vpn.scm
AgeCommit message (Collapse)Author
2021-04-20services: wireguard: Add keep-alive support.Guillaume Le Vaillant
* gnu/services/vpn.scm (<wireguard-peer>): Add 'keep-alive' field. (wireguard-configuration-file): Use it. * doc/guix.texi (VPN Services): Document it.
2021-02-17services: wireguard: New service.Mathieu Othacehe
* gnu/services/vpn.scm (wireguard-peer, wireguard-configuration): New records. (wireguard-service-type): New variable. * doc/guix.texi (VPN Services): Document it.
2020-11-18gnu: vpn: Make ca, key and cert optional.Julien Lepiller
* gnu/services/vpn.scm (openvpn-client-configuration) (openvpn-server-configuration): Make ca, key an cert fields optional. * doc/guix.texi (VPN Services): Document the change.
2020-02-19gnu: services: Add openvpn options.Julien Lepiller
* gnu/services/vpn.scm (openvpn-client-configuration) (openvpn-server-configuration): Add fast-io? and auth-user-pass options.
2020-02-19gnu: services: Fix openvpn boolean fields.Julien Lepiller
* gnu/services/vpn.scm (serialize-boolean): Do not print #t to the file.