# Patch snarfed from # http://http.debian.net/debian/pool/main/k/kobodeluxe/kobodeluxe_0.5.1-8.debian.tar.xz # # Disable reading of configs, graphics, and data from the current directory. # So it's safe to run kobodeluxe from anywhere w/o worry about an attacker # feeding it bad data. --- kobodeluxe-0.5.1.orig/kobo.cpp +++ kobodeluxe-0.5.1/kobo.cpp @@ -141,21 +141,21 @@ * Graphics data */ /* Current dir; from within the build tree */ - fmap->addpath("GFX", "./data/gfx"); + //fmap->addpath("GFX", "./data/gfx"); /* Real data dir */ fmap->addpath("GFX", "DATA>>gfx"); /* Current dir */ - fmap->addpath("GFX", "./gfx"); + //fmap->addpath("GFX", "./gfx"); /* * Sound data */ /* Current dir; from within the build tree */ - fmap->addpath("SFX", "./data/sfx"); + //fmap->addpath("SFX", "./data/sfx"); /* Real data dir */ fmap->addpath("SFX", "DATA>>sfx"); /* Current dir */ - fmap->addpath("SFX", "./sfx"); + //fmap->addpath("SFX", "./sfx"); /* * Score files (user and global) @@ -173,7 +173,7 @@ /* System local */ fmap->addpath("CONFIG", SYSCONF_DIR); /* In current dir (last resort) */ - fmap->addpath("CONFIG", "./"); + //fmap->addpath("CONFIG", "./"); } '>refslogtreecommitdiff
path: root/gnu/machine.scm
AgeCommit message (Collapse)Author
2020-07-25utils: Move <location> and '&error-location' to (guix diagnostics).Ludovic Courtès
* guix/utils.scm (<location>, source-properties->location) (location->source-properties, &error-location): Move to... * guix/diagnostics.scm: ... here. * gnu.scm: Adjust imports accordingly. * gnu/machine.scm: Likewise. * gnu/system.scm: Likewise. * gnu/tests.scm: Likewise. * guix/inferior.scm: Likewise. * tests/channels.scm: Likewise. * tests/packages.scm: Likewise.
2020-02-09Update e-mail address for Jakob L. Kreuze.Tobias Geerinckx-Rice
As requested here: <https://lists.gnu.org/archive/html/guix-devel/2020-02/msg00128.html>. * .mailmap: Add an entry for Jakob. * gnu/machine.scm, gnu/machine/digital-ocean.scm, gnu/machine/ssh.scm, gnu/packages/admin.scm, gnu/packages/i2p.scm, gnu/packages/music.scm, gnu/packages/web.scm, gnu/tests/reconfigure.scm, guix/scripts/deploy.scm, guix/scripts/system/reconfigure.scm: Update their e-mail address.
2019-12-08machine: Remove unnecessary record self-referencing bindings.Ludovic Courtès
'this-machine' and 'this-machine-ssh-configuration' were useless given that there are no thunked fields. * gnu/machine.scm (<machine>)[this-machine]: Remove. * gnu/machine/ssh.scm (<machine-ssh-configuration>) [this-machine-ssh-configuration]: Remove.
2019-12-07machine: Add provenance tracking to each machine operating system.Ludovic Courtès
* gnu/machine.scm (<machine>): Rename accessor to '%machine-operating-system'. (machine-operating-system): New procedure. * doc/guix.texi (Service Reference): Mention it.
2019-08-15machine: Implement 'roll-back-machine'.Jakob L. Kreuze
* gnu/machine.scm (roll-back-machine, &deploy-error, deploy-error?) (deploy-error-should-roll-back) (deploy-error-captured-args): New variable. * gnu/machine/ssh.scm (roll-back-managed-host): New variable. * guix/scripts/deploy.scm (guix-deploy): Roll-back systems when a deployment fails.
2019-08-06machine: Rename 'system' field.Jakob L. Kreuze
* gnu/machine.scm (machine-system): Delete variable. (machine-operating-system): New variable. All callers changed. * doc/guix.texi (Invoking guix deploy): Use the 'machine-operating-system' accessor rather than 'machine-system'.