From: Emile CARRY Date: Wed, 6 Apr 2016 00:27:17 +0200 Subject: midicon segmentation fault Debian-Bug: https://bugs.debian.org/819897 Forwarded: no --- sound/a_midicon.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/sound/a_midicon.c b/sound/a_midicon.c index 57de3cf..ded2988 100644 --- a/sound/a_midicon.c +++ b/sound/a_midicon.c @@ -120,8 +120,8 @@ static inline void __press(unsigned ch, unsigned key) { m[ch].next[key] = -1; m[ch].prev[key] = m[ch].last; - m[ch].next[m[ch].last] = (char)key; m[ch].last = (char)key; + m[ch].next[m[ch].last] = (char)key; } fed25c6f9bca95bbae9f85e333be70a6ee0'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
AgeCommit message (Expand)Author
2021-04-10gnu: ghc-wai-cors: Fix typo in description....* gnu/packages/haskell-web.scm (ghc-wai-cors)[description]: Fix typo. Tobias Geerinckx-Rice
2020-12-06gnu: Add ghc-wai-cors....* gnu/packages/haskell-web.scm (ghc-wai-cors): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com> Giacomo Leidi
2020-12-06gnu: Add ghc-wai-handler-launch....* gnu/packages/haskell-web.scm (ghc-wai-handler-launch): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com> Giacomo Leidi
2020-12-06gnu: Add ghc-yesod-static....* gnu/packages/haskell-web.scm (ghc-yesod-static): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com> Giacomo Leidi
2020-12-06gnu: Add ghc-hjsmin....* gnu/packages/haskell-web.scm (ghc-hjsmin): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com> Giacomo Leidi
2020-12-06gnu: Add ghc-wai-app-static....* gnu/packages/haskell-web.scm (ghc-wai-app-static): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com> Giacomo Leidi
2020-12-06gnu: Add ghc-yesod-test....* gnu/packages/haskell-web.scm (ghc-yesod-test): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com> Giacomo Leidi
2020-12-06gnu: ghc-yesod-core: Update to 1.6.17.2....* gnu/packages/haskell-web.scm (ghc-yesod-core): Update to 1.6.17.2. Signed-off-by: Timothy Sample <samplet@ngyro.com> Giacomo Leidi
2020-11-20gnu: Add ghc-http-reverse-proxy....* gnu/packages/haskell-web.scm (ghc-http-reverse-proxy): New variable. Alexandru-Sergiu Marton