# This was created in responce to Debian bug #163979
# Thing is, if you want to compant "-1" with a char value,
# you better make that char signed
--- kobodeluxe-0.5.1.orig/graphics/window.cpp
+++ kobodeluxe-0.5.1/graphics/window.cpp
@@ -331,7 +331,7 @@
}
-void window_t::center_token(int _x, int _y, const char *txt, char token)
+void window_t::center_token(int _x, int _y, const char *txt, signed char token)
{
center_token_fxp(PIXEL2CS(_x), PIXEL2CS(_y), txt, token);
}
@@ -374,7 +374,7 @@
}
-void window_t::center_token_fxp(int _x, int _y, const char *txt, char token)
+void window_t::center_token_fxp(int _x, int _y, const char *txt, signed char token)
{
_x = CS2PIXEL((_x * xs + 128) >> 8);
_y = CS2PIXEL((_y * ys + 128) >> 8);
--- kobodeluxe-0.5.1.orig/graphics/window.h
+++ kobodeluxe-0.5.1/graphics/window.h
@@ -265,10 +265,10 @@
void font(int fnt);
void string(int _x, int _y, const char *txt);
void center(int _y, const char *txt);
- void center_token(int _x, int _y, const char *txt, char token = 0);
+ void center_token(int _x, int _y, const char *txt, signed char token = 0);
void string_fxp(int _x, int _y, const char *txt);
void center_fxp(int _y, const char *txt);
- void center_token_fxp(int _x, int _y, const char *txt, char token = 0);
+ void center_token_fxp(int _x, int _y, const char *txt, signed char token = 0);
int textwidth(const char *txt, int min = 0, int max = 255);
int textwidth_fxp(const char *txt, int min = 0, int max = 255);
int fontheight();
8afd1f'>diff
|
Age | Commit message (Expand) | Author |
2023-03-04 | gnu: mig: Remove dependency on Perl....* gnu/packages/hurd.scm (mig)[inputs]: Remove PERL.
[arguments]: Remove 'patch-non-shebang-references' phase and add
'avoid-perl-dependency' phase.
| Ludovic Courtès |
2023-02-05 | gnu: Rename 'guile-3.0/fixed' to 'guile-3.0/pinned'....* gnu/packages/guile.scm: Rename variable 'guile-3.0/fixed' to
'guile-3.0/pinned', add deprecation.
* etc/release-manifest.scm (%packages-to-cross-build): Replace
'guile-3.0/fixed' with 'guile-3.0/pinned'.
* gnu/packages/autotools.scm (make-autoconf-wrapper)[inputs]: Likewise.
* gnu/packages/commencement.scm (guile-final): Likewise.
Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
| Simon Tournier |
2022-10-28 | gnu: diffutils: Skip failing test on GNU/Hurd....* gnu/packages/base.scm (diffutils)[arguments]: Add #:make-flags.
* gnu/packages/commencement.scm (diffutils-boot0)[arguments]: Adjust to always
use substitute-keyword-arguments.
| Christopher Baines |
2022-10-28 | gnu: findutils: Skip failing test on GNU/Hurd....* gnu/packages/base.scm (findutils)[arguments]: Add #:make-flags.
* gnu/packages/commencement.scm (findutils-boot0)[arguments]: Likewise.
| Ludovic Courtès |
2022-07-19 | gnu: commencement: Explicitly provide the source of 'tcc-boot'....* gnu/packages/commencement.scm (tcc-boot)[source]: Remove dependency on
tcc.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Ekaitz Zarraga |
2022-06-05 | gnu: commencement: Remove unnecessary uses of 'bootstrap-origin'....* gnu/packages/commencement.scm (gnumach-headers-boot0): Remove
unnecessary 'package-with-bootstrap-guile'.
(hurd-source-boot0): Remove unnecessary 'bootstrap-origin'.
| Ludovic Courtès |
2022-06-05 | gnu: commencement: Fetch bootstrap tarballs from ftp.gnu.org too....As a side effect, this ensures those tarballs are eventually archived by
Software Heritage.
* gnu/packages/commencement.scm (tcc-boot0)[source]: Add "mirror://gnu"
URL.
(gnumach-headers-boot0)[source]: Likewise.
(hurd-source-boot0): Likewise.
| Ludovic Courtès |
2022-05-24 | gnu: gcc-toolchain: Add 12.1.0....* gnu/packages/commencement.scm (gcc-toolchain-12): New variable.
| Ludovic Courtès |
2022-05-12 | gnu: commencement: Remove redundant import....Reported by Josselin Poiret on #guix.
* gnu/packages/commencement.scm: Remove redundant #:use-module (guix gexp).
| Ludovic Courtès |