# This was created in responce to Debian bug #163979 # Thing is, if you want to compant "-1" with a char value, # you better make that char signed --- kobodeluxe-0.5.1.orig/graphics/window.cpp +++ kobodeluxe-0.5.1/graphics/window.cpp @@ -331,7 +331,7 @@ } -void window_t::center_token(int _x, int _y, const char *txt, char token) +void window_t::center_token(int _x, int _y, const char *txt, signed char token) { center_token_fxp(PIXEL2CS(_x), PIXEL2CS(_y), txt, token); } @@ -374,7 +374,7 @@ } -void window_t::center_token_fxp(int _x, int _y, const char *txt, char token) +void window_t::center_token_fxp(int _x, int _y, const char *txt, signed char token) { _x = CS2PIXEL((_x * xs + 128) >> 8); _y = CS2PIXEL((_y * ys + 128) >> 8); --- kobodeluxe-0.5.1.orig/graphics/window.h +++ kobodeluxe-0.5.1/graphics/window.h @@ -265,10 +265,10 @@ void font(int fnt); void string(int _x, int _y, const char *txt); void center(int _y, const char *txt); - void center_token(int _x, int _y, const char *txt, char token = 0); + void center_token(int _x, int _y, const char *txt, signed char token = 0); void string_fxp(int _x, int _y, const char *txt); void center_fxp(int _y, const char *txt); - void center_token_fxp(int _x, int _y, const char *txt, char token = 0); + void center_token_fxp(int _x, int _y, const char *txt, signed char token = 0); int textwidth(const char *txt, int min = 0, int max = 255); int textwidth_fxp(const char *txt, int min = 0, int max = 255); int fontheight(); ests/pypi.scm'>
path: root/tests/pypi.scm
AgeCommit message (Expand)Author
2024-06-03import: utils: End package descriptions with period....Herman Rimm
2023-05-31tests: Use quasiquoted 'match' patterns for package sexps....Ludovic Courtès
2023-05-31upstream: Replace 'input-changes' field by 'inputs'....Ludovic Courtès
2023-05-31tests: pypi: Rewrite tests using a local HTTP server....Ludovic Courtès
2023-05-31tests: pypi: Factorize tarball and wheel file creation....Ludovic Courtès
2023-04-30import: pypi: Adjust tests for new build system....Ludovic Courtès
2022-02-11tests: Adjust pypi test to recent changes....Ludovic Courtès
2022-01-26import: pypi: Convert hyphens to underscores in PyPI URLs if needed....Vivien Kraus
2021-11-18tests: Adjust opam and pypi tests to simplified inputs....Ludovic Courtès
2021-11-17Merge branch 'master' into core-updates-frozenLudovic Courtès