This patch changes libkmod so it honors the 'LINUX_MODULE_DIRECTORY' environment variable, rather than looking for modules exclusively in /lib/modules. Patch by Shea Levy and Eelco Dolstra, from Nixpkgs; adjusted to use 'LINUX_MODULE_DIRECTORY' rather than 'MODULE_DIR' as the variable name. --- kmod-7/libkmod/libkmod.c 2012-03-15 08:19:16.750010226 -0400 +++ kmod-7/libkmod/libkmod.c 2012-04-04 15:21:29.532074313 -0400 @@ -200,7 +200,7 @@ static char *get_kernel_release(const char *dirname) { struct utsname u; - char *p; + char *p, *dirname_prefix; if (dirname != NULL) return path_make_absolute_cwd(dirname); @@ -208,7 +208,10 @@ if (uname(&u) < 0) return NULL; - if (asprintf(&p, "%s/%s", dirname_default_prefix, u.release) < 0) + if ((dirname_prefix = getenv("LINUX_MODULE_DIRECTORY")) == NULL) + dirname_prefix = dirname_default_prefix; + + if (asprintf(&p, "%s/%s", dirname_prefix, u.release) < 0) return NULL; return p; --- kmod-17/tools/static-nodes.c 2013-12-17 22:05:42.159047316 +0100 +++ kmod-17/tools/static-nodes.c 2014-04-17 13:51:17.945974320 +0200 @@ -159,6 +159,7 @@ FILE *in = NULL, *out = NULL; const struct static_nodes_format *format = &static_nodes_format_human; int r, ret = EXIT_SUCCESS; + char *dirname_prefix; for (;;) { int c, idx = 0, valid; @@ -211,16 +212,19 @@ goto finish; } - snprintf(modules, sizeof(modules), "/lib/modules/%s/modules.devname", kernel.release); + if ((dirname_prefix = getenv("LINUX_MODULE_DIRECTORY")) == NULL) + dirname_prefix = "/lib/modules"; + + snprintf(modules, sizeof(modules), "%s/%s/modules.devname", dirname_prefix, kernel.release); in = fopen(modules, "re"); if (in == NULL) { if (errno == ENOENT) { - fprintf(stderr, "Warning: /lib/modules/%s/modules.devname not found - ignoring\n", - kernel.release); + fprintf(stderr, "Warning: %s/%s/modules.devname not found - ignoring\n", + dirname_prefix, kernel.release); ret = EXIT_SUCCESS; } else { - fprintf(stderr, "Error: could not open /lib/modules/%s/modules.devname - %m\n", - kernel.release); + fprintf(stderr, "Error: could not open %s/%s/modules.devname - %m\n", + dirname_prefix, kernel.release); ret = EXIT_FAILURE; } goto finish; a>/hurd.scm
AgeCommit message (Expand)Author
2023-07-13system: hurd: Add netdde to %base-packages/hurd....Janneke Nieuwenhuizen
2023-06-17gnu: Use target-hurd?, system-hurd? instead of hurd-target?, hurd-system?....Janneke Nieuwenhuizen
2023-03-30system: hurd: Use shepherd-0.8 in the package list....Josselin Poiret
2023-03-03services: base: Deprecate 'syslog-service' procedure....Bruno Victal
2022-11-28system: hurd: Create more ttys....Ludovic Courtès
2022-04-08system: hurd: Fix bogus 'initrd-modules' field....Ludovic Courtès
2022-03-09system: hurd: Move the Shepherd before the Hurd in %BASE-PACKAGES/HURD....Ludovic Courtès
2021-12-12services: Define '%loopback-static-networking'....Ludovic Courtès
2021-12-12services: Define '%qemu-static-networking'....Ludovic Courtès
2021-12-12services: static-networking: Change interface to mimic netlink....Ludovic Courtès
2021-10-18system: hurd: Add 'info-reader' to %BASE-PACKAGES/HURD....Ludovic Courtès