Description: Fix building kiwix-desktop with libkiwix-12.1.0 Bug: https://github.com/kiwix/kiwix-desktop/issues/964 Origin: https://github.com/kiwix/kiwix-desktop/commit/1b322d8f01c787846546a6473f153cf1daa41e65 Applied-Upstream: https://github.com/kiwix/kiwix-desktop/commit/1b322d8f01c787846546a6473f153cf1daa41e65 --- From 1b322d8f01c787846546a6473f153cf1daa41e65 Mon Sep 17 00:00:00 2001 From: Matthieu Gautier Date: Thu, 9 Feb 2023 09:47:47 +0100 Subject: [PATCH] With last version of libkiwix, Downloader now return shared_ptr. --- src/contentmanager.cpp | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/src/contentmanager.cpp b/src/contentmanager.cpp index c2f4ff9..d4db50a 100644 --- a/src/contentmanager.cpp +++ b/src/contentmanager.cpp @@ -173,7 +173,7 @@ QStringList ContentManager::updateDownloadInfos(QString id, const QStringList &k return values; } auto& b = mp_library->getBookById(id); - kiwix::Download* d; + std::shared_ptr d; try { d = mp_downloader->getDownload(b.getDownloadId()); } catch(...) { @@ -270,7 +270,7 @@ QString ContentManager::downloadBook(const QString &id) for (auto b : booksList) if (b.toStdString() == book.getId()) return ""; - kiwix::Download *download; + std::shared_ptr download; try { std::pair downloadDir("dir", downloadPath.toStdString()); const std::vector> options = { downloadDir }; -- 2.41.0 alue='4a58794095b77760466e8ef7e024723bdbed2bd3'/>
AgeCommit message (Expand)Author
2023-05-31nls: Update translations....* doc/guix-cookbook.texi (Top): Mention Slovak. Florian Pelz
2023-03-07nls: Update translations.Julien Lepiller
2022-12-04nls: Update translations....po/packages/vi.po: New file. po/packages/LINGUAS: Add it. Julien Lepiller
2022-11-04nls: Update translations....* po/guix/lt.po: New file. * po/guix/LINGUAS: Add lt. Julien Lepiller
2022-10-06nls: Update translations.Julien Lepiller
2022-09-04nls: Update translations.Julien Lepiller
2022-08-10nls: Update translations....po/guix/bn.po: New file. po/guix/LINGUAS: Add it. Julien Lepiller
2022-07-09nls: Update translations....po/guix/tr.po: New file. po/guix/LINGUAS: Add it. Julien Lepiller
2022-06-04nls: Update translations....po/packages/tr.po: New file. po/packages/LINGUAS: Add it. Julien Lepiller
2022-05-01nls: Update translations....po/guix/ja.po: New file. po/guix/LINGUAS: Add it. Julien Lepiller
2022-04-02nls: Update translations....* po/packages/fi.po: New file. * po/packages/LINGUAS: Add it. Julien Lepiller
2022-03-01nls: Update translations....* po/doc/guix-cookbook.uk.po: New file. * po/doc/local.mk: Add uk cookbook. * doc/local.mk: Add uk cookbook. * po/guix/fa.po: New file. * po/guix/uk.po: New file. * po/guix/LINGUAS: Add fa and uk. Julien Lepiller
2022-02-04nls: Update translations....* po/doc/guix-cookbook.pt_BR.po: New file. * po/doc/local.mk: Add it. * doc/local.mk: Add pt_BR cookbook. Julien Lepiller