Search the "extra libs" in GUIX_KF5INIT_LIB_PATH (which basically is a collection of all /lib directories). We can not hard-code the full path to the libsKF5Plasam, since adding palse-workspace Adopted from NixOS pkgs/development/libraries/kde-frameworks/kinit/kdeinit-extra_libs.patch =================================================================== --- kinit-5.32.0/src/kdeinit/kinit-5.32.0/src/kdeinit/.orig +++ kinit-5.32.0/src/kdeinit/kinit.cpp @@ -96,9 +96,9 @@ "libKF5Parts.5.dylib", "libKF5Plasma.5.dylib" #else - "libKF5KIOCore.so.5", - "libKF5Parts.so.5", - "libKF5Plasma.so.5" + "GUIX_PKGS_KF5_KIO/lib/libKF5KIOCore.so.5", + "GUIX_PKGS_KF5_PARTS/lib/libKF5Parts.so.5", + "GUIX_PKGS_KF5_PLASMA/lib/libKF5Plasma.so.5" #endif }; #endif @@ -1533,20 +1531,6 @@ static int initXconnection() } #endif -#ifndef Q_OS_OSX -// Find a shared lib in the lib dir, e.g. libkio.so. -// Completely unrelated to plugins. -static QString findSharedLib(const QString &lib) -{ - QString path = QFile::decodeName(CMAKE_INSTALL_PREFIX "/" LIB_INSTALL_DIR "/") + lib; - if (QFile::exists(path)) { - return path; - } - // We could also look in LD_LIBRARY_PATH, but really, who installs the main libs in different prefixes? - return QString(); -} -#endif - extern "C" { static void secondary_child_handler(int) @@ -1673,7 +1673,7 @@ #if defined(Q_OS_UNIX) && !defined(Q_OS_OSX) if (!d.suicide && qEnvironmentVariableIsEmpty("KDE_IS_PRELINKED")) { for (const char *extra_lib : extra_libs) { - const QString extra = findSharedLib(QString::fromLatin1(extra_lib)); + const QString extra = QString::fromLatin1(extra_lib); if (!extra.isEmpty()) { QLibrary l(extra); l.setLoadHints(QLibrary::ExportExternalSymbolsHint);
path: root/gnu/packages/hardware.scm
AgeCommit message (Expand)Author
2019-03-24gnu: ddcutil: Update to 0.9.5....* gnu/packages/hardware.scm (ddcutil): Update to 0.9.5. Tobias Geerinckx-Rice
2019-02-17gnu: wavemon: Update to 0.9.0....* gnu/packages/hardware.scm (wavemon): Update to 0.9.0. Tobias Geerinckx-Rice
2019-02-17gnu: ddcutil: Update to 0.9.4....* gnu/packages/hardware.scm (ddcutil): Update to 0.9.4. Tobias Geerinckx-Rice
2018-10-24gnu: Add wavemon....* gnu/packages/hardware.scm (wavemon): New public variable. Tobias Geerinckx-Rice
2018-10-04gnu: ddcutil: Update to 0.9.2....* gnu/packages/hardware.scm (ddcutil): Update to 0.9.2. Tobias Geerinckx-Rice
2018-10-04gnu: Add memtester....* gnu/packages/hardware.scm (memtester): New public variable. Tobias Geerinckx-Rice
2018-10-04gnu: Add memtest86+....* gnu/packages/hardware.scm (memtest86+): New public variable. Tobias Geerinckx-Rice
2018-08-30gnu: Add msr-tools....* gnu/packages/hardware.scm (msr-tools): New public variable. Tobias Geerinckx-Rice
2018-08-30gnu: Add ddcutil....* gnu/packages/hardware.scm: New file. (ddcutil): New public variable. * gnu/local.mk (GNU_SYSTEM_MODULES): Add the new file. Tobias Geerinckx-Rice