Search the "extra libs" in GUIX_KF5INIT_LIB_PATH (which basically is a
collection of all /lib directories). We can not hard-code the full path to the
libsKF5Plasam, since adding palse-workspace
Adopted from NixOS
pkgs/development/libraries/kde-frameworks/kinit/kdeinit-extra_libs.patch
===================================================================
--- kinit-5.32.0/src/kdeinit/kinit-5.32.0/src/kdeinit/.orig
+++ kinit-5.32.0/src/kdeinit/kinit.cpp
@@ -96,9 +96,9 @@
"libKF5Parts.5.dylib",
"libKF5Plasma.5.dylib"
#else
- "libKF5KIOCore.so.5",
- "libKF5Parts.so.5",
- "libKF5Plasma.so.5"
+ "GUIX_PKGS_KF5_KIO/lib/libKF5KIOCore.so.5",
+ "GUIX_PKGS_KF5_PARTS/lib/libKF5Parts.so.5",
+ "GUIX_PKGS_KF5_PLASMA/lib/libKF5Plasma.so.5"
#endif
};
#endif
@@ -1673,7 +1673,7 @@
#if defined(Q_OS_UNIX) && !defined(Q_OS_OSX)
if (!d.suicide && qEnvironmentVariableIsEmpty("KDE_IS_PRELINKED")) {
for (const char *extra_lib : extra_libs) {
- const QString extra = findSharedLib(QString::fromLatin1(extra_lib));
+ const QString extra = QString::fromLatin1(extra_lib);
if (!extra.isEmpty()) {
QLibrary l(extra);
l.setLoadHints(QLibrary::ExportExternalSymbolsHint);
scm?id=6e20d190dccccbce33750cbdbe4a95f95bf8d87f'>treecommitdiff
|
Age | Commit message (Expand) | Author |
2020-04-13 | gnu: autogen: Disable parallel tests....* gnu/packages/autogen.scm (autogen)[arguments]: Add #:parallel-tests?.
| Marius Bakke |
2019-02-24 | gnu: autogen: Update to 5.18.16....* gnu/packages/autogen.scm (autogen): Update to 5.18.16.
[inputs]: Update to guile-2.2.
[arguments]: Add ‘--disable-dependency-tracking’ to #:configure-flags.
Re-indent.
| Tobias Geerinckx-Rice |
2018-08-09 | gnu: autogen: Update to 5.18.14....* gnu/packages/autogen.scm (autogen): Update to 5.18.14.
[inputs]: Move perl from native-inputs to here...
[native-inputs]: ...and which from inputs to here.
[arguments]: Remove unnecessary ‘/usr/bin/tr’ substitution.
| Tobias Geerinckx-Rice |