Add placeholder for kinit's store file name. diff --git a/src/kdeinitinterface.cpp b/src/kdeinitinterface.cpp index 22fa5e5..3d40937 100644 --- a/src/kdeinitinterface.cpp +++ b/src/kdeinitinterface.cpp @@ -52,7 +52,7 @@ void KDEInitInterface::ensureKdeinitRunning() // If not found in system paths, search other paths if (srv.isEmpty()) { const QStringList searchPaths = QStringList() - << QCoreApplication::applicationDirPath() // then look where our application binary is located + << QString::fromUtf8("@SUBSTITUTEME@/bin") // using QStringLiteral would be more efficient, but breaks guix store reference detection. << QLibraryInfo::location(QLibraryInfo::BinariesPath); // look where exec path is (can be set in qt.conf) srv = QStandardPaths::findExecutable(QStringLiteral("kdeinit5"), searchPaths); if (srv.isEmpty()) { >Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/tests.scm
AgeCommit message (Expand)Author
2019-03-25accounts: Add default value for the 'home-directory' field of <user-account>....Ludovic Courtès
2018-08-29tests: Warn about test module load failures....Ludovic Courtès
2018-05-28system: Remove uses of the 'title' field of <file-system>....Ludovic Courtès
2018-02-19marionette: Use QEMU's "VM channel" mechanism....Ludovic Courtès
2018-01-09tests: marionette-operating-system: Add initrd parameter and kernel-arguments....Danny Milosavljevic
2017-12-06gnu, doc, tests: Use ‘bootloader-configuration’ everywhere....Tobias Geerinckx-Rice
2017-08-23gnu: bootloader: Deprecate "device" field in favor of "target"....Andy Wingo