This patch fixes a bug and related test failure on platforms where 'char' is unsigned. Taken from upstream: https://github.com/open-source-parsers/jsoncpp/commit/f11611c8785082ead760494cba06196f14a06dcb diff --git a/src/lib_json/json_writer.cpp b/src/lib_json/json_writer.cpp index 8e06cca2..56195dc1 100644 --- a/src/lib_json/json_writer.cpp +++ b/src/lib_json/json_writer.cpp @@ -178,8 +178,9 @@ static bool isAnyCharRequiredQuoting(char const* s, size_t n) { char const* const end = s + n; for (char const* cur = s; cur < end; ++cur) { - if (*cur == '\\' || *cur == '\"' || *cur < ' ' || - static_cast(*cur) < 0x80) + if (*cur == '\\' || *cur == '\"' || + static_cast(*cur) < ' ' || + static_cast(*cur) >= 0x80) return true; } return false; -scripts'>koszko-scripts Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
AgeCommit message (Collapse)Author
2024-06-24manifest: Streamline; add packages useful for patch review/submission.Maxim Cournoyer
* manifest.scm: Fix alternate command line invocation (which would not consider 'manifest.scm'). Use specifications instead of packages. Remove perl (now in the guix package's native inputs). Add b4, git, git:send-email, mumi, nss-certs, openssl and patman to the manifest. Change-Id: I49d92dda059856ce217cea9054a466a1754dcf94 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
2024-04-02maint: Add perl to the manifest.Janneke Nieuwenhuizen
* manifest.scm: Add perl. Change-Id: Ie70cea1eb4d62f2a649292209391a92abdae2288
2024-01-31maint: Add gnupg to the manifest.Ludovic Courtès
* manifest.scm: Add gnupg. Change-Id: Id5e90f87e5c3a07aa3e49afa97cc0b6d3ce71b41
2023-09-18maint: Support `guix shell' in Guix's git archive with manifest.scm.Janneke Nieuwenhuizen
* manifest.scm: New file. * Makefile.am (EXTRA_DIST): Add it. * doc/contributing.texi (Building from Git): Mention using it.