Various fixes for building with GCC 10.
Taken from Debian:
https://sources.debian.org/patches/jfsutils/1.1.15-5/gcc10_fix-1.patch/
--- jfsutils-1.1.15.old/fscklog/display.c 2005-11-22 21:43:54.000000000 +0100
+++ jfsutils-1.1.15.new/fscklog/display.c 2020-05-21 18:15:13.410617620 +0200
@@ -54,7 +54,7 @@
* output: fsck extracted service log I/O buffer
*
*/
-char xchklog_buffer[XCHKLOG_BUFSIZE];
+static char xchklog_buffer[XCHKLOG_BUFSIZE];
/* + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
*
diff -ur --exclude '*.o' --exclude '*.a' jfsutils-1.1.15.old/libfs/logredo.c jfsutils-1.1.15.new/libfs/logredo.c
--- jfsutils-1.1.15.old/libfs/logredo.c 2005-11-22 21:43:55.000000000 +0100
+++ jfsutils-1.1.15.new/libfs/logredo.c 2020-05-21 18:19:44.927703271 +0200
@@ -87,9 +87,9 @@
* S T U F F F O R T H E L O G
*
*/
-struct logsuper logsup; /* log super block */
-int32_t numdoblk; /* number of do blocks used