Subject: [PATCH] openjfx: Determine the version of Java in JDK_HOME
Icedtea contains guix in its version, so build.gradle failes to run. Openjfx
packaging is not trivial, so you will probably need to try build it with
gradlew.
---
build.gradle | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/build.gradle b/build.gradle
index df82f63..2c626cd 100644
--- a/build.gradle
+++ b/build.gradle
@@ -742,9 +742,9 @@ try {
if (inStream.readLine() != null) {
String v = inStream.readLine();
if (v != null) {
- int ib = v.indexOf(" (build ");
+ int ib = v.indexOf(" (guix build ");
if (ib != -1) {
- String ver = v.substring(ib + 8, v.size() - 1);
+ String ver = v.substring(ib + 13, v.size() - 1);
defineProperty("jdkRuntimeVersion", ver)
defineProperty("jdkVersion", jdkRuntimeVersion.split("-")[0])
2.24.1
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2020-08-16 | gnu: webkitgtk: Expose all font locations to the bubblewrap sandbox....Fixes <https://issues.guix.gnu.org/41174> and <https://issues.guix.gnu.org/42618>.
The webkitgtk library relied on by Epiphany and others uses bubblewrap to
sandbox its process. This sandbox was only exposing fonts relative to
XDG_DATA_HOME. Extend it so that it honors font locations specified via
XDG_DATA_DIRS as well, which is what Guix uses.
* gnu/packages/patches/webkitgtk-bind-all-fonts.patch: Add patch.
* gnu/local.mk: Register it.
* gnu/packages/webkit.scm (webkitgtk)[source]<patches>: Use it.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
| Leo Prikler |