Subject: [PATCH] openjfx: Determine the version of Java in JDK_HOME
Icedtea contains guix in its version, so build.gradle failes to run. Openjfx
packaging is not trivial, so you will probably need to try build it with
gradlew.
---
build.gradle | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/build.gradle b/build.gradle
index df82f63..2c626cd 100644
--- a/build.gradle
+++ b/build.gradle
@@ -742,9 +742,9 @@ try {
if (inStream.readLine() != null) {
String v = inStream.readLine();
if (v != null) {
- int ib = v.indexOf(" (build ");
+ int ib = v.indexOf(" (guix build ");
if (ib != -1) {
- String ver = v.substring(ib + 8, v.size() - 1);
+ String ver = v.substring(ib + 13, v.size() - 1);
defineProperty("jdkRuntimeVersion", ver)
defineProperty("jdkVersion", jdkRuntimeVersion.split("-")[0])
2.24.1
td class='sub right'>
Age | Commit message (Expand) | Author |
2021-12-22 | tests: Move keys into ./tests/keys/ and add a third ed25519 key....The third key will be used in an upcoming commit.
Rename public keys to .pub.
* guix/tests/gnupg.scm (%ed25519-3-public-key-file): New variable.
(%ed25519-3-secret-key-file): New variable.
(%ed25519-2-public-key-file): Renamed from %ed25519bis-public-key-file.
(%ed25519-2-secret-key-file): Renamed from %ed25519bis-secret-key-file.
* tests/keys/ed25519-3.key: New file.
* tests/keys/ed25519-3.sec: New file.
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
| Attila Lendvai |