)
# md4c
-set(BUILD_MD2HTML_EXECUTABLE OFF CACHE BOOL "Don't build md2html executable" FORCE)
-set(BUILD_SHARED_LIBS OFF CACHE BOOL "Don't build shared md4c library" FORCE)
-add_subdirectory(3rdparty/md4c EXCLUDE_FROM_ALL)
-list(APPEND CLIENT_LINK_DIRS ${MD4C_BINARY_DIR}/src)
-list(APPEND CLIENT_INCLUDE_DIRS ${MD4C_SOURCE_DIR}/src)
-list(APPEND CLIENT_LIBS md4c-html)
+find_package(md4c)
+if(md4c_FOUND)
+ message(STATUS "Using system-provided md4c-html")
+ list(APPEND CLIENT_LIBS md4c::md4c-html)
+else()
+ message("Using bundled md4c-html library")
+ set(BUILD_MD2HTML_EXECUTABLE OFF CACHE BOOL "Don't build md2html executable" FORCE)
+ set(BUILD_SHARED_LIBS OFF CACHE BOOL "Don't build shared md4c library" FORCE)
+ add_subdirectory(3rdparty/md4c EXCLUDE_FROM_ALL)
+ list(APPEND CLIENT_LINK_DIRS ${MD4C_BINARY_DIR}/src)
+ list(APPEND CLIENT_INCLUDE_DIRS ${MD4C_SOURCE_DIR}/src)
+ list(APPEND CLIENT_LIBS md4c-html)
+endif()
# tidy-html5
-set(BUILD_SHARED_LIB OFF CACHE BOOL "Don't build shared tidy library" FORCE)
-set(SUPPORT_CONSOLE_APP OFF CACHE BOOL "Don't build tidy console app" FORCE)
-add_subdirectory(3rdparty/tidy-html5 EXCLUDE_FROM_ALL)
-list(APPEND CLIENT_LINK_DIRS ${tidy_BINARY_DIR}/Release)
-list(APPEND CLIENT_INCLUDE_DIRS ${tidy_SOURCE_DIR}/include)
-list(APPEND CLIENT_LIBS tidy-static)
+pkg_check_modules(tidy IMPORTED_TARGET tidy)
+if(tidy_FOUND)
+ message(STATUS "Using system-provided tidy")
+ list(APPEND CLIENT_LIBS PkgConfig::tidy)
+else()
+ message("Using bundled tidy library")
+ set(BUILD_SHARED_LIB OFF CACHE BOOL "Don't build shared tidy library" FORCE)
+ set(SUPPORT_CONSOLE_APP OFF CACHE BOOL "Don't build tidy console app" FORCE)
+ add_subdirectory(3rdparty/tidy-html5 EXCLUDE_FROM_ALL)
+ list(APPEND CLIENT_LINK_DIRS ${tidy_BINARY_DIR}/Release)
+ list(APPEND CLIENT_INCLUDE_DIRS ${tidy_SOURCE_DIR}/include)
+ list(APPEND CLIENT_LIBS tidy-static)
+endif()
# common executable sources
qt_add_executable(
base-commit: a4300308dc8d03d59f620bb5fed753df5cf31ed9
--
2.41.0
5-23 23:38:52 +0200'>2021-05-23gnu: Respect the root file-system's CHECK? field.... | Tobias Geerinckx-Rice |
2020-12-17 | linux-boot: Fix noresume argument parsing.... | Tobias Geerinckx-Rice |
2020-11-07 | linux-boot: Resume from hibernation.... | Tobias Geerinckx-Rice |
2020-09-07 | linux-boot: Handle nfs-root device strings.... | Stefan |
2020-06-08 | hurd-boot: Further cleanup of "rc".... | Jan (janneke) Nieuwenhuizen |
2020-06-08 | linux-boot: Update 'make-hurd-device-nodes'.... | Jan (janneke) Nieuwenhuizen |
2020-05-20 | linux-boot: Refactor boot-system.... | Maxim Cournoyer |
2020-05-02 | Merge branch 'master' into core-updates | Marius Bakke |
2020-05-02 | linux-boot: Allow the root file system to be mounted via NFS.... | Stefan |
2020-04-11 | linux-boot: Add 'make-hurd-device-nodes'.... | Ludovic Courtès |
2020-04-11 | linux-boot: 'make-essential-device-nodes' root parameter is optional.... | Ludovic Courtès |
2020-03-02 | linux-boot: Ensure volatile root is mounted read-only.... | Maxim Cournoyer |
2019-12-12 | linux-boot: Don't ignore flags when mounting root file system.... | Guillaume Le Vaillant |
2019-11-18 | linux-boot: Don't ignore options when mounting root file system.... | Guillaume Le Vaillant |
2019-11-18 | linux-boot: Fix indentation.... | Maxim Cournoyer |