Fix the broken Texinfo in the Jacal package documentation
--- jacal/jacal.texi,orig 2017-02-23 20:35:55.303980444 +0100
+++ jacal/jacal.texi 2017-02-23 20:53:14.539024674 +0100
@@ -343,7 +343,7 @@
With the standard input grammar, the precedence of @samp{-} as a prefix
behaves strangely. @code{a^-b*c} becomes @code{a^(-b*c)} while
-@code{@result{a^b*c} (a^b)*c}.
+@code{a^b*c @result{} (a^b)*c}.
Using @code{divide} to divide a polynomial by an integer does not work.
@@ -675,8 +675,9 @@
e1: ---------
a
@end example
+@end deffn
-@deffnx Command suchthat var exp
+@deffn Command suchthat var exp
If an expression rather than an equation is given to @code{suchthat}, it
is as though the equation @code{@var{exp}=0} was given.
@@ -688,8 +689,9 @@
e2: ---------
a
@end example
+@end deffn
-@deffnx Operator | var exp_or_eqn
+@deffn Operator | var exp_or_eqn
An alternative infix notation is also available for @code{suchthat}.
@@ -857,8 +859,9 @@
Returns the degree of polynomial or equation @var{poly} in variable
@var{var}.
+@end deffn
-@deffnx Operator degree poly
+@deffn Operator degree poly
Returns the total-degree, the degree of its highest degree monomial,
of polynomial or equation @var{poly}.
@@ -1016,10 +1019,12 @@
Returns @var{poly1} reduced with respect to @var{poly2} (or @var{eqn})
and @var{var}. If @var{poly2} is univariate, the third argument is not
needed.
+@end deffn
-@deffnx Command mod poly1 n
+@deffn Command mod poly1 n
Returns @var{poly1} with all the coefficients taken modulo @var{n}.
-@deffnx Command mod poly1
+@end deffn
+@deffn Command mod poly1
Returns @var{poly1} with all the coefficients taken modulo the
current modulus.
@@ -1220,8 +1225,9 @@
e1: -1 2 3 5
@end group
@end example
+@end deffn
-@deffnx Command factor polyratio
+@deffn Command factor polyratio
Given a univariate ratio of polynomials @var{polyratio}, returns a
matrix of factors and exponents.
@@ -2028,7 +2034,7 @@
formed from the pair-wise products of components of the inputs. For
example, for the input tensors @code{x[a,b]} and @code{y[c]}
@example
-@result{z:tmult(x,y);} z[a,b,c] = x[a,b]*y[c]
+z:tmult(x,y); @result{} z[a,b,c] = x[a,b]*y[c]
@end example
With an additional argument, @code{tmult} will produce the inner product
@@ -2464,8 +2470,9 @@
If you do not wish to return to Jacal but really want to terminate the
session and return to the operating system, then after typing
@code{qed();}, type @code{(slib:exit)} or use @code{quit}.
+@end deffn
-@deffnx Command quit
+@deffn Command quit
Exit directly from Jacal to the operating system. You will not be able
to continue your Jacal session.
tr>
2022-05-25 | Move (gnu platform) and (gnu platforms ...) to guix/....* gnu/platform.scm:
* gnu/platforms/arm.scm:
* gnu/platforms/hurd.scm:
* gnu/platforms/mips.scm:
* gnu/platforms/powerpc.scm:
* gnu/platforms/riscv.scm:
* gnu/platforms/s390.scm:
* gnu/platforms/x86.scm: Move to guix/.
* Makefile.am:
* doc/guix.texi (Porting to a New Platform):
* etc/release-manifest.scm:
* gnu/ci.scm:
* gnu/image.scm:
* gnu/local.mk:
* gnu/packages/bioinformatics.scm:
* gnu/packages/bootstrap.scm:
* gnu/packages/cross-base.scm:
* gnu/packages/instrumentation.scm:
* gnu/packages/linux.scm:
* gnu/system/image.scm:
* gnu/system/images/hurd.scm:
* gnu/system/images/novena.scm:
* gnu/system/images/pine64.scm:
* gnu/system/images/pinebook-pro.scm:
* gnu/system/images/rock64.scm:
* guix/scripts/build.scm:
* guix/scripts/system.scm:
* guix/self.scm: Update (gnu platform...) to (guix platform...).
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
| Josselin Poiret |
2022-05-22 | platform: Add glibc-dynamic-linker field....* gnu/platform.scm (<platform>)[glibc-dynamic-linker]: New field.
(platform-glibc-dynamic-linker, lookup-platform-by-system): New procedures.
* gnu/platforms/arm.scm (armhf-linux, aarch64-linux): Add the glibc-dynamic-linker field.
* gnu/platforms/hurd.scm (hurd): Ditto.
* gnu/platforms/intel.scm (intel32-linux, intel64-linux, intel32-mingw, intel64-linux): Ditto.
* gnu/platforms/mips.scm (mips64el-linux): Ditto.
* gnu/platforms/powerpc.scm (powerpc-linux, powerpc64-linux): Ditto.
* gnu/platforms/riscv.scm (riscv64-linux): Ditto.
* gnu/platforms/s390.scm (riscv64-linux): Ditto.
* gnu/packages/bootstrap.scm (glibc-dynamic-linker): Adapt it.
| Mathieu Othacehe |
2022-01-14 | gnu: bootstrap: Add support for riscv64-linux....On 7d93b21ab1c132990054372a9677c1639d54e631
gnu: glibc-for-bootstrap: Update patch.
Run
./pre-inst-env guix build --target=riscv64-linux-gnu bootstrap-tarballs
Producing
/gnu/store/4hdzva9i0wyyfbgj1lmqc1wkk644pv07-bootstrap-tarballs-0
With guix hash -rx
1nj0fdgj08bbmfny01mp2blv7c3p2iciqh31zmf04ap5s7ygsqlp
* gnu/packages/bootstrap.scm (%bootstrap-executables): Add entries for
riscv64-linux.
(%bootstrap-guile-hash, %bootstrap-coreutils&co, %bootstrap-binutils,
%bootstrap-glibc, %bootstrap-gcc): Add entry for riscv64-linux.
(raw-build-guile3): New procedure.
(make-raw-bag): Use raw-build-guile3 for riscv64-linux.
* guix/packages.scm (%supported-systems): Add riscv64-linux.
(%cuirass-supported-systems): Remove riscv64-linux.
* guix/utils.scm (target-64bit?): Add riscv64-linux.
* m4/guix.m4: Add riscv64-linux as a supported system.
* doc/guix.texi (GNU Distribution): Add riscv64-linux.
| Efraim Flashner |