Add aarch64 support to config.guess and config.sub, as would be found if using a more recent version of autoconf. --- config.guess | 7 +++++++ config.sub | 1 + 2 files changed, 8 insertions(+) diff --git a/config.guess b/config.guess index 40eaed4..baad294 100755 --- a/config.guess +++ b/config.guess @@ -861,6 +861,13 @@ EOF i*86:Minix:*:*) echo ${UNAME_MACHINE}-pc-minix exit ;; + aarch64:Linux:*:*) + echo ${UNAME_MACHINE}-unknown-linux-gnu + exit ;; + aarch64_be:Linux:*:*) + UNAME_MACHINE=aarch64_be + echo ${UNAME_MACHINE}-unknown-linux-gnu + exit ;; alpha:Linux:*:*) case `sed -n '/^cpu model/s/^.*: \(.*\)/\1/p' < /proc/cpuinfo` in EV5) UNAME_MACHINE=alphaev5 ;; diff --git a/config.sub b/config.sub index 30fdca8..8f5b018 100755 --- a/config.sub +++ b/config.sub @@ -247,6 +247,7 @@ case $basic_machine in # Some are omitted here because they have special meanings below. 1750a | 580 \ | a29k \ + | aarch64 | aarch64_be \ | alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \ | alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \ | am33_2.0 \ -- 2.9.0 store'>logtreecommitdiff
path: root/nix/libstore
AgeCommit message (Expand)Author
2024-03-12daemon: Address shortcoming in previous security fix for CVE-2024-27297....Ludovic Courtès
2024-03-11daemon: Protect against FD escape when building fixed-output derivations (CVE......Ludovic Courtès
2024-01-05daemon: Change default ‘timeout’ and ‘max-silent-time’ values....Ludovic Courtès
2023-12-17daemon: Fix my own whitespace errors....Tobias Geerinckx-Rice
2023-12-10daemon: Sacrifice builders on OOM....Tobias Geerinckx-Rice
2023-12-11daemon: Implement ‘substitute-urls’ RPC....Ludovic Courtès
2023-12-04daemon: Simplify “empty status” substitute error message....Ludovic Courtès
2023-09-26daemon: Add “git-download” built-in builder....Ludovic Courtès
2023-09-09daemon: Fix build with GCC 13....Sören Tempel
2022-12-18daemon: Make "opening file" error messages distinguishable....Ludovic Courtès
2022-10-17Revert "nix: Guard against removing temporary roots of living processes."...Ludovic Courtès
2022-10-07nix: Guard against removing temporary roots of living processes....Ludovic Courtès
2022-09-11daemon: Remove unused function findOutput....Maxime Devos
2022-09-11daemon: Remove unused function exportPaths....Maxime Devos
2022-09-11daemon: Remove unused function openStore....Maxime Devos