Add aarch64 support to config.guess and config.sub, as would be found if using a more recent version of autoconf. --- config.guess | 7 +++++++ config.sub | 1 + 2 files changed, 8 insertions(+) diff --git a/config.guess b/config.guess index 40eaed4..baad294 100755 --- a/config.guess +++ b/config.guess @@ -861,6 +861,13 @@ EOF i*86:Minix:*:*) echo ${UNAME_MACHINE}-pc-minix exit ;; + aarch64:Linux:*:*) + echo ${UNAME_MACHINE}-unknown-linux-gnu + exit ;; + aarch64_be:Linux:*:*) + UNAME_MACHINE=aarch64_be + echo ${UNAME_MACHINE}-unknown-linux-gnu + exit ;; alpha:Linux:*:*) case `sed -n '/^cpu model/s/^.*: \(.*\)/\1/p' < /proc/cpuinfo` in EV5) UNAME_MACHINE=alphaev5 ;; diff --git a/config.sub b/config.sub index 30fdca8..8f5b018 100755 --- a/config.sub +++ b/config.sub @@ -247,6 +247,7 @@ case $basic_machine in # Some are omitted here because they have special meanings below. 1750a | 580 \ | a29k \ + | aarch64 | aarch64_be \ | alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \ | alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \ | am33_2.0 \ -- 2.9.0 >logtreecommitdiff
path: root/.gitignore
AgeCommit message (Expand)Author
2020-09-17guix-install.sh: Support OpenRC....Morgan Smith
2020-07-17gitignore: Don't ignore daemon source code....Jakub Kądziołka
2020-06-28.gitignore: Ignore 'etc/committer.scm'....Brice Waegeneire
2020-05-16etc: Add a systemd unit to bind-mount @storedir@ read-only....Tobias Geerinckx-Rice
2020-05-14etc: indent-code.el: Use the --quick option....Maxim Cournoyer
2020-03-30.gitignore: Ignore test results in tests/services....Marius Bakke
2020-03-11Add system start-up files for guix-daemon....Danny Milosavljevic
2019-09-24Merge branch 'master' into core-updatesLudovic Courtès
2019-09-18doc: Add Guix Cookbook....Ricardo Wurmus
2019-06-14build: Remove 'gnu/packages/bootstrap' and its binaries....Ludovic Courtès
2019-04-26bootstrap: Break automake dependency on generated files....Miguel Ángel Arruga Vivas