Add aarch64 support to config.guess and config.sub, as would be found if using
a more recent version of autoconf.
---
config.guess | 7 +++++++
config.sub | 1 +
2 files changed, 8 insertions(+)
diff --git a/config.guess b/config.guess
index 40eaed4..baad294 100755
--- a/config.guess
+++ b/config.guess
@@ -861,6 +861,13 @@ EOF
i*86:Minix:*:*)
echo ${UNAME_MACHINE}-pc-minix
exit ;;
+ aarch64:Linux:*:*)
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
+ exit ;;
+ aarch64_be:Linux:*:*)
+ UNAME_MACHINE=aarch64_be
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
+ exit ;;
alpha:Linux:*:*)
case `sed -n '/^cpu model/s/^.*: \(.*\)/\1/p' < /proc/cpuinfo` in
EV5) UNAME_MACHINE=alphaev5 ;;
diff --git a/config.sub b/config.sub
index 30fdca8..8f5b018 100755
--- a/config.sub
+++ b/config.sub
@@ -247,6 +247,7 @@ case $basic_machine in
# Some are omitted here because they have special meanings below.
1750a | 580 \
| a29k \
+ | aarch64 | aarch64_be \
| alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
| am33_2.0 \
--
2.9.0
'active' href='/guix/log/gnu/packages/libreoffice.scm'>logtreecommitdiff
|
Age | Commit message (Expand) | Author |
2024-08-31 | gnu: LibreOffice: Build with libxcrypt....Glibc 2.38 no longer includes libcrypt by default, so we provide this
functionality via libxcrypt.
https://sourceware.org/glibc/wiki/Release/2.38#Building_libcrypt_is_disabled_by_default
* gnu/packages/libreoffice.scm (libreoffice)[inputs]: Add libxcrypt.
Change-Id: I3c9e02abb420a710d3a71bf137187dd989eb0398
| Leo Famulari |
2024-06-13 | gnu: libreoffice: Update to 7.6.7.2....* gnu/packages/libreoffice.scm (libreoffice): Update to 7.6.7.2.
* gnu/packages/hunspell.scm (hunspell-dict-he-il,
hunspell-dict-it-it): Update to 7.6.7.2.
Change-Id: I289a0b2b9648930b46102c055c642c333a4229fd
Co-authored-by: Ludovic Courtès <ludo@gnu.org>
| Nicolas Graves |
2024-03-26 | gnu: orcus: Update to 0.19.2....* gnu/packages/libreoffice.scm (orcus): Update to 0.19.2.
Change-Id: I965428ba271bcdf0bcc9b31984cf628a09495b6b
| Efraim Flashner |
2024-03-26 | gnu: libcmis: Update to 0.6.2....* gnu/packages/libreoffice.scm (libcmis): Update to 0.6.2.
[arguments]: Remove a configure-flag setting the location of the boost
libraries.
Change-Id: I9145e1e8bf31ea0354efef8255160c3530ebe639
| Efraim Flashner |