From 8b350daa847dd8e131d9e6b5b4434ce68a7903d0 Mon Sep 17 00:00:00 2001 From: Dmitry Polyakov Date: Wed, 4 Aug 2021 15:46:33 +0500 Subject: [PATCH] Add support for INSTEAD_GAMES_PATH In some setups, users might prefer to determine on their own the path in which games are located. This patch enables them to do so by setting the “INSTEAD_GAMES_PATH” environmnent variable. --- src/main.c | 6 ++++++ 1 file changed, 6 insertions(+) diff --git a/src/main.c b/src/main.c index ba0ada1d..b05497b8 100644 --- a/src/main.c +++ b/src/main.c @@ -394,6 +394,12 @@ int instead_main(int argc, char *argv[]) setdir(game_cwd); profile_load(NULL); + char *gamespath_env = NULL; + + if (gamespath_env = getenv("INSTEAD_GAMES_PATH"), gamespath_env != NULL) { + games_sw = strdup(gamespath_env); + } + for (i = 1; i < argc; i++) { if (lua_sw) /* during load profile */ break; -- 2.32.0 Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/read-print.scm
AgeCommit message (Expand)Author
2022-09-20read-print: Correctly support multiple same-named newline forms....Ludovic Courtès
2022-09-02read-print: Define forms for which \n, \t, etc. are not escaped....Ludovic Courtès
2022-09-01read-print: Guess the base to use for integers being printed....Ludovic Courtès
2022-08-10read-print: Report missing closing parens instead of looping....Ludovic Courtès
2022-08-08read-print: Add 'case' and 'cond' special forms....Ludovic Courtès
2022-08-08read-print: Support printing multi-line comments....Ludovic Courtès
2022-08-08read-print: 'canonicalize-comment' leaves top-level comments unchanged....Ludovic Courtès
2022-08-08read-print: Add code to read and write sequences of expressions/blanks....Ludovic Courtès
2022-08-08read-print: Recognize page breaks....Ludovic Courtès
2022-08-08read-print: Read and render vertical space....Ludovic Courtès
2022-08-08style: Move reader and printer to (guix read-print)....Ludovic Courtès