From 8b350daa847dd8e131d9e6b5b4434ce68a7903d0 Mon Sep 17 00:00:00 2001 From: Dmitry Polyakov Date: Wed, 4 Aug 2021 15:46:33 +0500 Subject: [PATCH] Add support for INSTEAD_GAMES_PATH In some setups, users might prefer to determine on their own the path in which games are located. This patch enables them to do so by setting the “INSTEAD_GAMES_PATH” environmnent variable. --- src/main.c | 6 ++++++ 1 file changed, 6 insertions(+) diff --git a/src/main.c b/src/main.c index ba0ada1d..b05497b8 100644 --- a/src/main.c +++ b/src/main.c @@ -394,6 +394,12 @@ int instead_main(int argc, char *argv[]) setdir(game_cwd); profile_load(NULL); + char *gamespath_env = NULL; + + if (gamespath_env = getenv("INSTEAD_GAMES_PATH"), gamespath_env != NULL) { + games_sw = strdup(gamespath_env); + } + for (i = 1; i < argc; i++) { if (lua_sw) /* during load profile */ break; -- 2.32.0 lue='switch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/tla2tools-build-xml.patch
ommit/gnu/tests/mail.scm?id=a37e03d60e18dfcf119d0b92d9008e54fc350bf1'>tests: opensmtpd: Check /var/spool/mail instead of /var/mail....
AgeCommit message (Expand)Author
Ludovic Courtès
2020-03-16tests: opensmtpd: Gracefully handle test failure....Ludovic Courtès
2020-03-09tests: getmail: Provide a pre-initialized user account password....Ludovic Courtès
2020-01-31gnu: Update opensmtpd configuration grammar....Tobias Geerinckx-Rice
2020-01-20tests: mail: Remove %getmail-os from the bottom of the file....Christopher Baines
2019-06-19tests: Fix opensmtpd test....Tobias Geerinckx-Rice
2019-05-31services: Add getmail....Christopher Baines