From 8b350daa847dd8e131d9e6b5b4434ce68a7903d0 Mon Sep 17 00:00:00 2001 From: Dmitry Polyakov Date: Wed, 4 Aug 2021 15:46:33 +0500 Subject: [PATCH] Add support for INSTEAD_GAMES_PATH In some setups, users might prefer to determine on their own the path in which games are located. This patch enables them to do so by setting the “INSTEAD_GAMES_PATH” environmnent variable. --- src/main.c | 6 ++++++ 1 file changed, 6 insertions(+) diff --git a/src/main.c b/src/main.c index ba0ada1d..b05497b8 100644 --- a/src/main.c +++ b/src/main.c @@ -394,6 +394,12 @@ int instead_main(int argc, char *argv[]) setdir(game_cwd); profile_load(NULL); + char *gamespath_env = NULL; + + if (gamespath_env = getenv("INSTEAD_GAMES_PATH"), gamespath_env != NULL) { + games_sw = strdup(gamespath_env); + } + for (i = 1; i < argc; i++) { if (lua_sw) /* during load profile */ break; -- 2.32.0 '>Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/guix.scm
AgeCommit message (Expand)Author
2022-11-20services: guix-build-coordinator: Remove duplicate log timestamp....Christopher Baines
2022-10-11services: guix: Include max-allocated-builds gbc agent option....Christopher Baines
2022-07-15gnu: tests: Fix guix-data-service test....Timotej Lazar
2022-07-03services: guix-build-coordinator: Fix passing parallel-hooks....Christopher Baines
2022-07-01services: guix: Support guix-build-coordinator parallel hooks....Christopher Baines
2022-06-05services: guix-data-service: Increase timeout for service start....Timotej Lazar
2022-05-25gnu: guix-build-coordinator: Update to 0-53.3de63f1....Christopher Baines
2022-04-22services: nar-herder: Allow specifying the log level....Christopher Baines