Fix build with Poppler 22.9.0. Taken from upstream: https://gitlab.com/inkscape/inkscape/-/commit/fb00794923d19cfbb2ca4adca3ae8971553a06be diff --git a/src/extension/internal/pdfinput/pdf-parser.cpp b/src/extension/internal/pdfinput/pdf-parser.cpp index cca1e840966c7940a1af472025535042b07e3e0f..80d64c9b866d5d3dd095636a9a02571b89061af1 100644 --- a/src/extension/internal/pdfinput/pdf-parser.cpp +++ b/src/extension/internal/pdfinput/pdf-parser.cpp @@ -697,7 +697,11 @@ void PdfParser::opSetDash(Object args[], int /*numArgs*/) _POPPLER_FREE(obj); } } +#if POPPLER_CHECK_VERSION(22, 9, 0) + state->setLineDash(std::vector (dash, dash + length), args[1].getNum()); +#else state->setLineDash(dash, length, args[1].getNum()); +#endif builder->updateStyle(state); } diff --git a/src/extension/internal/pdfinput/svg-builder.cpp b/src/extension/internal/pdfinput/svg-builder.cpp index 12f71dd9214b95dbad6fdf7642a96cdd57f2c64a..9fc56fe63c2feee986ad1ff5018e679a0bacb665 100644 --- a/src/extension/internal/pdfinput/svg-builder.cpp +++ b/src/extension/internal/pdfinput/svg-builder.cpp @@ -389,10 +389,17 @@ void SvgBuilder::_setStrokeStyle(SPCSSAttr *css, GfxState *state) { sp_repr_css_set_property(css, "stroke-miterlimit", os_ml.str().c_str()); // Line dash - double *dash_pattern; int dash_length; double dash_start; +#if POPPLER_CHECK_VERSION(22, 9, 0) + const double *dash_pattern; + const std::vector &dash = state->getLineDash(&dash_start); + dash_pattern = dash.data(); + dash_length = dash.size(); +#else + double *dash_pattern; state->getLineDash(&dash_pattern, &dash_length, &dash_start); +#endif if ( dash_length > 0 ) { Inkscape::CSSOStringStream os_array; for ( int i = 0 ; i < dash_length ; i++ ) { e='q' value=''/>
it/README?id=c75a80189fc19f6ff8b4c82d1d1801be6763b6d2'>doc: Update README to refer to the manual....
AgeCommit message (Expand)Author
2020-07-25Use 'formatted-message' instead of '&message' where appropriate....Ludovic Courtès
2020-07-25utils: Move '&fix-hint' to (guix diagnostics)....Ludovic Courtès
2020-07-25utils: Move <location> and '&error-location' to (guix diagnostics)....Ludovic Courtès
Ludovic Courtès
2019-11-09doc: Mention value /var to localstatedir option....zimoun
2019-09-04doc: Update 'README'....Ludovic Courtès
2019-01-09build: Require Guile 2.2....Ludovic Courtès
2018-12-02Make Guile-JSON a required dependency....Eric Bavier
2018-11-23Update Guile-SQLite3 URL everywhere....Ludovic Courtès
2018-09-04Switch to Guile-Gcrypt....Ludovic Courtès
2018-06-27doc: Specify Guile-SQLite3 minimum version....Ludovic Courtès
2018-06-14build: Require Guile-SQLite3....Ludovic Courtès