This patch adds support for Poppler 0.76 and later. Taken from upstream: diff --git a/src/extension/internal/pdfinput/pdf-parser.cpp b/src/extension/internal/pdfinput/pdf-parser.cpp index 8484984bdf..4f798e35bf 100644 --- a/src/extension/internal/pdfinput/pdf-parser.cpp +++ b/src/extension/internal/pdfinput/pdf-parser.cpp @@ -421,7 +421,7 @@ void PdfParser::parse(Object *obj, GBool topLevel) { error(errInternal, -1, "Weird page contents"); return; } - parser = new Parser(xref, new Lexer(xref, obj), gFalse); + parser = new _POPPLER_NEW_PARSER(xref, obj); go(topLevel); delete parser; parser = nullptr; diff --git a/src/extension/internal/pdfinput/poppler-transition-api.h b/src/extension/internal/pdfinput/poppler-transition-api.h index 61a15083a0..5e8bc4ae90 100644 --- a/src/extension/internal/pdfinput/poppler-transition-api.h +++ b/src/extension/internal/pdfinput/poppler-transition-api.h @@ -14,6 +14,13 @@ #include +#if POPPLER_CHECK_VERSION(0, 76, 0) +#define _POPPLER_NEW_PARSER(xref, obj) Parser(xref, obj, gFalse) +#else +#define _POPPLER_NEW_PARSER(xref, obj) Parser(xref, new Lexer(xref, obj), gFalse) +#endif + + #if POPPLER_CHECK_VERSION(0, 72, 0) #define getCString c_str #endif services/mail.scm?id=f19cf27c2b9ff92e2c0fd931ef7fde39c376adaa'>commitdiff
AgeCommit message (Expand)Author
2020-04-21services: dovecot: 'stop' method returns #f upon success....Ludovic Courtès
2020-03-16tests: opensmtpd: Check /var/spool/mail instead of /var/mail....Ludovic Courtès
2020-01-31gnu: Update opensmtpd configuration grammar....Tobias Geerinckx-Rice
2019-09-21services: dovecot: Fix predicate names for free-form fields...Alexey Abramov
2019-06-20services: opensmtpd: Extend the PAM service....Kristofer Buffington
2019-06-20services: Fix typo in (gnu services mail) exports....Tobias Geerinckx-Rice
2019-05-07services: dovecot: Rename auth-verbose-passwords?....Christopher Baines
2019-04-07services: Add 'imap4d-service-type'....宋文武
2019-03-13Remove traces of "GuixSD"....Ludovic Courtès
2018-11-10services: dovecot: Set correct default value for the "auth" service....Clément Lassieur
2018-11-10services: dovecot: Allow to set 'process-limit'....Clément Lassieur
2018-11-10services: dovecot: Allow to set 'client-limit'....Clément Lassieur
2018-03-09services: dovecot: Copy dovecot.conf to /etc/dovecot....Oleg Pykhalov
2017-12-23gnu: dovecot: Update to 2.3.0....Tobias Geerinckx-Rice