From 512668dfd92b20d0d08b91d62b422d8262573281 Mon Sep 17 00:00:00 2001 From: Dirk Lemstra Date: Wed, 24 Mar 2021 20:37:15 +0100 Subject: [PATCH] Throw exception when no exception was raised but status was false (#3432). --- coders/dcm.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/coders/dcm.c b/coders/dcm.c index 7a68ed6e8..ed17c9567 100644 --- a/coders/dcm.c +++ b/coders/dcm.c @@ -3989,6 +3989,8 @@ static Image *ReadDCMImage(const ImageInfo *image_info,ExceptionInfo *exception) if (redmap != (int *) NULL) redmap=(int *) RelinquishMagickMemory(redmap); image=DestroyImageList(image); + if ((status == MagickFalse) && (exception->severity < ErrorException)) + ThrowReaderException(CorruptImageError,"CorruptImage"); return(GetFirstImageInList(images)); } if (info.depth != (1UL*MAGICKCORE_QUANTUM_DEPTH)) -- 2.31.0 k's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
AgeCommit message (Expand)Author
2016-11-29gnu: spice: Use libjpeg-turbo instead of libjpeg....Tobias Geerinckx-Rice
2016-08-22gnu: spice: Update to 0.12.8 [fixes CVE-2016-{0749,2150}]....David Craven
2016-08-15gnu: usbredir: Invoke autoreconf directly....David Craven
2016-08-15gnu: usbredir: Add git commit to version....David Craven
2016-08-13gnu: spice: Fix usbredir for 32 bit platforms....David Craven
2016-08-05gnu: spice-vdagent: Set Exec path in spice-vdagent.desktop....David Craven
2016-07-29gnu: virt-viewer: Remove SPICE-PROTOCOL from inputs....Leo Famulari
2016-07-29gnu: spice-gtk: Remove LIBUSB from inputs....Leo Famulari
2016-07-29gnu: spice-gtk: Propagate SPICE-PROTOCOL....Leo Famulari
2016-07-29gnu: usbredir: Propagate LIBUSB....Leo Famulari
2016-07-28gnu: Add virt-viewer....David Craven
2016-07-28gnu: Add spice-vdagent....David Craven
2016-07-28gnu: Add spice....David Craven
2016-07-28gnu: Add spice-gtk....David Craven
2016-07-28gnu: Add spice-protocol....David Craven
2016-07-28gnu: Add virglrenderer....David Craven
2016-07-28gnu: Add usbredir....David Craven