We omit the ChangeLog changes below, since they do not apply cleanly. From 6ee5059cd3ac8d82714a1ab1321399b88539abf0 Mon Sep 17 00:00:00 2001 From: Cristy Date: Mon, 30 Nov 2020 16:26:59 +0000 Subject: [PATCH] possible TIFF related-heap buffer overflow (alert & POC by Hardik Shah) --- ChangeLog | 6 ++++++ coders/tiff.c | 2 +- 2 files changed, 7 insertions(+), 1 deletion(-) diff --git a/coders/tiff.c b/coders/tiff.c index e98f927ab..1eecf17ae 100644 --- a/coders/tiff.c +++ b/coders/tiff.c @@ -1975,7 +1975,7 @@ static Image *ReadTIFFImage(const ImageInfo *image_info, extent+=image->columns*sizeof(uint32); #endif strip_pixels=(unsigned char *) AcquireQuantumMemory(extent, - sizeof(*strip_pixels)); + 2*sizeof(*strip_pixels)); if (strip_pixels == (unsigned char *) NULL) ThrowTIFFException(ResourceLimitError,"MemoryAllocationFailed"); (void) memset(strip_pixels,0,extent*sizeof(*strip_pixels)); s='sub right'>
aboutsummaryrefslogtreecommitdiff
path: root/gnu/system/locale.scm
AgeCommit message (Collapse)Author
2018-01-24system: Put locales where libc will find them.Mark H Weaver
* gnu/system/locale.scm (localedef-command, single-locale-directory): Use only the major+minor part of the libc version number in the locale directory name.
2017-07-17locale: Demonadify the locale creation API.Ludovic Courtès
* gnu/system/locale.scm (single-locale-directory): Use 'computed-file' instead of 'gexp->derivation'. (locale-directory): Adjust accordingly and do the same. * gnu/system.scm (operating-system-directory-base-entries): Adjust accordingly.
2017-07-17gnu: Remove glibc@2.21 and its traces.Ludovic Courtès
* gnu/packages/base.scm (glibc-2.21): Remove. * gnu/system/locale.scm (localedef-command)[maybe-version-directory]: Remove. Replace call with use of 'package-version'. (single-locale-directory): Remove 'version>=' conditional.
2017-07-11system: Refer to native packages when appropriate.Ludovic Courtès
* gnu/system/locale.scm (localedef-command): Use the native LIBC. * gnu/system/shadow.scm (default-skeletons): Use the native GUILE-WM.