diff -ruN id3lib-3.8.3.orig/ChangeLog id3lib-3.8.3/ChangeLog --- id3lib-3.8.3.orig/ChangeLog 2003-03-02 01:23:00.000000000 +0100 +++ id3lib-3.8.3/ChangeLog 2006-02-22 00:33:59.946214472 +0100 @@ -1,3 +1,8 @@ +2006-02-17 Jerome Couderc + + * Patch from Spoon to fix UTF-16 writing bug + http://sourceforge.net/tracker/index.php?func=detail&aid=1016290&group_id=979&atid=300979 + 2003-03-02 Sunday 17:38 Thijmen Klok * THANKS (1.20): added more people diff -ruN id3lib-3.8.3.orig/src/io_helpers.cpp id3lib-3.8.3/src/io_helpers.cpp --- id3lib-3.8.3.orig/src/io_helpers.cpp 2003-03-02 01:23:00.000000000 +0100 +++ id3lib-3.8.3/src/io_helpers.cpp 2006-02-22 00:35:02.926639992 +0100 @@ -363,11 +363,22 @@ // Write the BOM: 0xFEFF unicode_t BOM = 0xFEFF; writer.writeChars((const unsigned char*) &BOM, 2); + // Patch from Spoon : 2004-08-25 14:17 + // http://sourceforge.net/tracker/index.php?func=detail&aid=1016290&group_id=979&atid=300979 + // Wrong code + //for (size_t i = 0; i < size; i += 2) + //{ + // unicode_t ch = (data[i] << 8) | data[i+1]; + // writer.writeChars((const unsigned char*) &ch, 2); + //} + // Right code + unsigned char *pdata = (unsigned char *) data.c_str(); for (size_t i = 0; i < size; i += 2) { - unicode_t ch = (data[i] << 8) | data[i+1]; + unicode_t ch = (pdata[i] << 8) | pdata[i+1]; writer.writeChars((const unsigned char*) &ch, 2); } + // End patch } return writer.getCur() - beg; } e713c0d16d2cf767400a91034f2147770e31'>diff
path: root/doc/guix-cookbook.texi
AgeCommit message (Collapse)Author
2019-11-26doc: cookbook: Use @lisp for Scheme snippets.Ludovic Courtès
* doc/guix-cookbook.texi: Use @lisp instead of @example where appropriate.
2019-10-30doc: Explain how to switch profile from empty shell in "Profiles in Practice".Pierre Neidhardt
* doc/guix-cookbook.texi (Profiles in Practice): Add example.
2019-10-28doc: Link to SICP Info page in "A Scheme Crash Course".Pierre Neidhardt
* doc/guix-cookbook.texi (Scheme tutorials): Replace Emacs Info reader hint with more useful interactive link to SICP Info page.
2019-10-28doc: Finish importing the "Packaging Tutorial".Pierre Neidhardt
* doc/guix-cookbook.texi (Packaging Tutorial): Import all sections after the Scheme crash course.
2019-10-28doc: Fix some typos in "Guix Profiles in Practice".Pierre Neidhardt
* doc/guix-cookbook.texi (Guix Profiles in Practice): Fix typos.
2019-10-25doc: cookbook: Use "@lisp" for Scheme snippets.Ludovic Courtès
* doc/guix-cookbook.texi: Use @lisp for Scheme snippets instead of "@example scheme". This allows for syntax highlighting of the HTML output.
2019-10-24doc: Add "Guix Profiles in Practice" to the cookbook.Pierre Neidhardt
* doc/guix-cookbook.texi (Advanced package management): New chapter. * doc/guix-cookbook.texi (Guix Profiles in Practice): New section.
2019-09-18doc: Add Guix Cookbook.Ricardo Wurmus
* .gitignore: Update ignore list. * Makefile.am (assert-no-store-file-names): Exclude the cookbook. * bootstrap: Generate po files for cookbook translations. * doc/guix-cookbook.texi: New file. * doc/local.mk (info_TEXINFOS): Add it; add a rule to build cookbook translations. * po/doc/local.mk (DOC_COOKBOOK_PO_FILES): New variable. (EXTRA_DIST): Add cookbook pot file and po files. (doc-po-update-cookbook-%): New target. (doc-pot-update): Also update cookbook pot file. (doc-po-update): Also update cookbook po files.