From 919dd016be1abd213b3a7d0e9a3b79e3286ef6ad Mon Sep 17 00:00:00 2001 From: Simon South Date: Wed, 10 Jun 2020 13:02:09 -0400 Subject: [PATCH] aarch64: Use only C++98 This patch removes an unneeded C++ template that causes the build to fail for aarch64 using gcc 7.5.0 and its default support for only the C++98 standard. It is based on original work by Severin Gehwolf . See: https://bugzilla.redhat.com/show_bug.cgi?id=1307224 --- src/cpu/aarch64/vm/sharedRuntime_aarch64.cpp | 4 ---- 1 file changed, 4 deletions(-) diff --git a/src/cpu/aarch64/vm/sharedRuntime_aarch64.cpp b/src/cpu/aarch64/vm/sharedRuntime_aarch64.cpp index 0bc0a2b..6f73ca0 100644 --- a/src/cpu/aarch64/vm/sharedRuntime_aarch64.cpp +++ b/src/cpu/aarch64/vm/sharedRuntime_aarch64.cpp @@ -194,10 +194,6 @@ static int reg2offset_out(VMReg r) { return (r->reg2stack() + SharedRuntime::out_preserve_stack_slots()) * VMRegImpl::stack_slot_size; } -template static const T& min (const T& a, const T& b) { - return (a > b) ? b : a; -} - // --------------------------------------------------------------------------- // Read the array of BasicTypes from a signature, and compute where the // arguments should go. Values in the VMRegPair regs array refer to 4-byte -- 2.26.2 commitdiff
diff options
context:
space:
mode:
authorDariqq <dariqq@posteo.net>2024-08-29 08:35:21 +0000
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-08-31 15:26:54 +0200
commit19e0b937857563e77841a4fc5433589fa98c810d (patch)
tree0d51325fb6b91fa69e516317da657a1d78100dab /gnu/packages/guile.scm
parent6ab90024f1b873310322c61c6efa547434a90594 (diff)
downloadguix-19e0b937857563e77841a4fc5433589fa98c810d.tar.gz
guix-19e0b937857563e77841a4fc5433589fa98c810d.zip
gnu: pidgin: Use python3.
* gnu/packages/messaging.scm (pidgin)[inputs]: Replace python-2 with python-wrapper, and python2-dbus with python-dbus. Change-Id: Ia4b7b1e47da09e9648d10fae419cd473b3d6586e Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/guile.scm')
0 files changed, 0 insertions, 0 deletions