Re-enable the DHE (Ephemeral Diffie-Hellman) cipher suites, which IceCat 38.6.0 disabled by default to avoid the Logjam attack. This issue was fixed in NSS version 3.19.1 by limiting the lower strength of supported DHE keys to use 1023 bit primes, so we can enable these cipher suites safely. The DHE cipher suites are needed to allow IceCat to connect to many sites, including https://gnupg.org/. Patch by Mark H Weaver --- icecat-38.6.0/browser/app/profile/icecat.js.orig 1969-12-31 19:00:00.000000000 -0500 +++ icecat-38.6.0/browser/app/profile/icecat.js 2016-02-06 00:48:23.826170154 -0500 @@ -2061,12 +2061,6 @@ pref("security.ssl3.rsa_des_ede3_sha", false); pref("security.ssl3.ecdhe_ecdsa_rc4_128_sha", false); pref("security.ssl3.ecdhe_rsa_rc4_128_sha", false); -// https://directory.fsf.org/wiki/Disable_DHE -// Avoid logjam attack -pref("security.ssl3.dhe_rsa_aes_128_sha", false); -pref("security.ssl3.dhe_rsa_aes_256_sha", false); -pref("security.ssl3.dhe_dss_aes_128_sha", false); -pref("security.ssl3.dhe_rsa_des_ede3_sha", false); //Optional //Perfect forward secrecy // pref("security.ssl3.rsa_aes_256_sha", false); mk'>logtreecommitdiff
path: root/nix/local.mk
AgeCommit message (Expand)Author
2019-02-04daemon: Add "/guix" to default 'nixLibexecDir'....Ludovic Courtès
2019-02-04daemon: Remove unused 'NIX_DATA_DIR' environment variable....Ludovic Courtès
2018-11-14daemon: Install 'authenticate' script under LIBEXECDIR/guix....Ludovic Courtès
2018-06-22build: Remove leftover reference to nix/libstore/schema.sql....Ludovic Courtès
2018-06-14Remove 'guix-register' and its traces....Ludovic Courtès
2018-06-14database: 'with-database' can now initialize new databases....Ludovic Courtès
2018-06-08build: Do not add all of $(BUILT_SOURCES) to $(CLEANFILES)....Ludovic Courtès
2018-01-07daemon: Make libbz2 an optional dependency....Ludovic Courtès
2018-01-07daemon: Add gzip log compression....Ludovic Courtès
2017-03-06build: Don't embed absolute paths in .service and .conf service files....Leo Famulari
2016-12-20build: Delete all the .service and .conf files upon 'make clean'....Ludovic Courtès
2016-12-18build: Fix .service and .conf targets for VPATH builds....Ludovic Courtès
2016-12-18build: Add 'guix-publish.*.in' to the distribution....Ludovic Courtès
2016-11-24Add system start-up files for "guix publish"....Hartmut Goebel
2016-11-16daemon: Add "builtin:download" derivation builder....Ludovic Courtès
2016-10-28daemon: Factor out SQLite handling....Eelco Dolstra