Make some of the changes needed to the 'makeicecat' script, to allow it to run
in a snippet without network access. After this patch is applied, some
additional changes will be made using 'substitute*'.
diff --git a/makeicecat b/makeicecat
index bf2b7a6..bc3b19b 100755
--- a/makeicecat
+++ b/makeicecat
@@ -56,7 +56,7 @@ readonly SOURCEDIR=icecat-${FFVERSION}
# debug/shell options
readonly DEVEL=0
set -euo pipefail
-(( DEVEL )) && set -x
+set -x
###############################################################################
@@ -455,7 +455,7 @@ configure_search()
# Process various JSON pre-configuration dumps.
- python3 ../../tools/process-json-files.py . browser/components/extensions/schemas/
+ python3 "${DATADIR}"/../tools/process-json-files.py . browser/components/extensions/schemas/
}
configure_mobile()
@@ -837,12 +837,12 @@ finalize_sourceball()
# entry point
###############################################################################
-validate_env || exit 1
-prepare_env
-fetch_source
-verify_sources
-extract_sources
-fetch_l10n
+# validate_env || exit 1
+# prepare_env
+# fetch_source
+# verify_sources
+# extract_sources
+# fetch_l10n
apply_patches
configure
configure_search
@@ -854,4 +854,4 @@ prepare_macos_packaging
configure_extensions
configure_onboarding
apply_bugfixes
-finalize_sourceball
+# finalize_sourceball
b'>treecommitdiff
gnu: python-seaborn: Update to 0.13.1.
* gnu/packages/python-xyz.scm (python-seaborn): Update to 0.13.1.
[propagated-inputs]: Add python-ipykernel, python-mypy, python-nbconvert,
python-numpydoc, python-pyyaml, and python-statsmodels.
[native-inputs]: Add python-flake8, python-pre-commit, python-pytest-cov, and
python-pytest-xdist; remove python-pypa-build.
Change-Id: Id1ed6cfaf7e0950e99c06900fd68fb1ab884bee0
0 files changed, 0 insertions, 0 deletions