Make some of the changes needed to the 'makeicecat' script, to allow it to run
in a snippet without network access. After this patch is applied, some
additional changes will be made using 'substitute*'.
diff --git a/makeicecat b/makeicecat
index bf2b7a6..bc3b19b 100755
--- a/makeicecat
+++ b/makeicecat
@@ -56,7 +56,7 @@ readonly SOURCEDIR=icecat-${FFVERSION}
# debug/shell options
readonly DEVEL=0
set -euo pipefail
-(( DEVEL )) && set -x
+set -x
###############################################################################
@@ -928,12 +928,12 @@ finalize_sourceball()
# entry point
###############################################################################
-validate_env || exit 1
-prepare_env
-fetch_source
-verify_sources
-extract_sources
-fetch_l10n
+# validate_env || exit 1
+# prepare_env
+# fetch_source
+# verify_sources
+# extract_sources
+# fetch_l10n
apply_patches
configure
configure_search
@@ -945,4 +945,4 @@ prepare_macos_packaging
configure_extensions
configure_onboarding
apply_bugfixes
-finalize_sourceball
+# finalize_sourceball
href='/guix/'>summaryrefslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2023-10-05 | gnu: guile-ini: Added missing propagated input ‘guile-lib’....Fixes <https://issues.guix.gnu.org/66315>.
* gnu/packages/guile-xyz.scm (guile-ini)[propagated-inputs]: Add
GUILE-LIB.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Fabio Natali |
2023-10-04 | gnu: guile-mastodon: Update to 0.0.1-0a94ae6b...Message-ID: <0064c4ff9262c4906131909ae1276667033f8811.1696343806.git.ekaitz@elenq.tech>
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Tue, 3 Oct 2023 16:28:58 +0200
Subject: [PATCH] gnu: guile-mastodon: Update to 0.0.1-0a94ae6b
* gnu/packages/guile-xyz.scm (guile-mastodon): Update to 0.0.1-0a94ae6b
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
| Ekaitz Zarraga |
2023-09-25 | gnu: guile-fibers: Remove version from latest package....As I think this makes more sense, the version is only specified when you need
a specific previous release.
* gnu/packages/guile-xyz.scm (guile-fibers): Rename to guile-fibers-1.0.
(guile-fibers-1.3): Rename to guile-fibers.
(guile-fibers-1.1): Inherit from guile-fibers.
* gnu/packages/admin.scm (shepherd-0.10)[native-inputs]: Replace
guile-fibers-1.3 with guile-fibers.
* gnu/packages/ci.scm (cuirass)[inputs]: Likewise.
* gnu/packages/gnunet.scm (gnunet-scheme)[propagated-inputs,native-inputs]:
Likewise.
* gnu/packages/package-management.scm (guix-build-coordinator)
[inputs,propagated-inputs]: Likewise.
* gnu/packages/package-management.scm (nar-herder)[inputs,propagated-inputs]:
Likewise.
* gnu/packages/web.scm (guix-data-service)[propagated-inputs]: Likewise.
| Christopher Baines |