Make some of the changes needed to the 'makeicecat' script, to allow it to run
in a snippet without network access. After this patch is applied, some
additional changes will be made using 'substitute*'.
diff --git a/makeicecat b/makeicecat
index bf2b7a6..bc3b19b 100755
--- a/makeicecat
+++ b/makeicecat
@@ -56,7 +56,7 @@ readonly SOURCEDIR=icecat-${FFVERSION}
# debug/shell options
readonly DEVEL=0
set -euo pipefail
-(( DEVEL )) && set -x
+set -x
###############################################################################
@@ -455,7 +455,7 @@ configure_search()
# Process various JSON pre-configuration dumps.
- python3 ../../tools/process-json-files.py . browser/components/extensions/schemas/
+ python3 "${DATADIR}"/../tools/process-json-files.py . browser/components/extensions/schemas/
}
configure_mobile()
@@ -837,12 +837,12 @@ finalize_sourceball()
# entry point
###############################################################################
-validate_env || exit 1
-prepare_env
-fetch_source
-verify_sources
-extract_sources
-fetch_l10n
+# validate_env || exit 1
+# prepare_env
+# fetch_source
+# verify_sources
+# extract_sources
+# fetch_l10n
apply_patches
configure
configure_search
@@ -854,4 +854,4 @@ prepare_macos_packaging
configure_extensions
configure_onboarding
apply_bugfixes
-finalize_sourceball
+# finalize_sourceball
239b413ad787ad2d'>diff
|
Age | Commit message (Expand) | Author |
2024-04-18 | news: Add entry for nss-certs being added to %base-packages....* etc/news.scm: New entry.
* NEWS: Update news.
Change-Id: I40e0b859f2af0bb0e652925a53d6447ea6fbacfb
| Maxim Cournoyer |
2023-03-28 | NEWS: Mention new rpm format....* NEWS (Package management): Mention new rpm format.
| Maxim Cournoyer |
2022-12-18 | Update NEWS. | Ludovic Courtès |
2022-12-17 | Update NEWS. | Marius Bakke |
2022-12-02 | Update NEWS. | Ludovic Courtès |
2022-11-23 | NEWS: Update it....* NEWS: Shepherd is already at 0.9.3 now.
| Jonathan Brielmaier |
2022-11-16 | Update NEWS. | Maxim Cournoyer |
2022-10-13 | NEWS: Update it....* NEWS: Add an entry about 'guix shell' --emulate-fhs option.
| Mathieu Othacehe |
2022-10-07 | Update NEWS....* NEWS: Add new entry for installation script improvements.
| Maxim Cournoyer |
2022-09-28 | Update NEWS....* NEWS: Add new services for the 1.4.0.
| Mathieu Othacehe |
2022-09-26 | NEWS: Update it....* NEWS: Add an entry about WSL images.
| Mathieu Othacehe |
2022-09-24 | Update NEWS. | Ludovic Courtès |
2022-09-23 | Update NEWS. | Maxim Cournoyer |
2022-09-19 | Update NEWS....* NEWS: Mention Shepherd 0.9.2 upgrade.
| Mathieu Othacehe |
2022-09-16 | Update NEWS....Entries extracted from:
git log 3eadcdc63..version-1.4.0
* NEWS: Update entries for v1.4.0
| Mathieu Othacehe |
2022-09-15 | Update NEWS....This covers the commits made between v1.3.0..3eadcdc6^.
* NEWS: New entries for the 1.4.0 upcoming release.
| Maxim Cournoyer |
2022-09-14 | Update NEWS....These news were extracted from the output of:
git log --reverse v1.3.0..03eb0b1be2cfedd0d9a66fef0edc53a17f7653a5.
* NEWS: Update entries for v1.4.0.
| Maxim Cournoyer |