This avoids rumpdisk crash when booting without "noide".
Upstream status: Taken from Debian Salsa package git
https://salsa.debian.org/hurd-team/hurd/-/blob/f40ff84260b5a98bea949013415a1c92c127a43e/debian/patches/rumpdisk-no-hd
Index: hurd-debian/rumpdisk/block-rump.c
===================================================================
--- hurd-debian.orig/rumpdisk/block-rump.c
+++ hurd-debian/rumpdisk/block-rump.c
@@ -143,7 +143,6 @@ rumpdisk_device_init (void)
{
device_t device;
-#if 0
if (! device_open (device_master, D_READ, "hd0", &device)
|| ! device_open (device_master, D_READ, "hd1", &device)
|| ! device_open (device_master, D_READ, "hd3", &device)
@@ -154,7 +153,6 @@ rumpdisk_device_init (void)
disabled = 1;
return;
}
-#endif
if (! device_open (device_master, D_READ, "sd0", &device)
|| ! device_open (device_master, D_READ, "sd1", &device)
k's customized Guix
|
Age | Commit message (Expand) | Author |
2023-09-15 | services: guix: Add bffe-service-type....This is intended to replace the functionality of the Guix Build Coordinator
queue builds script, and also provide a web interface for build farms.
* gnu/services/guix.scm (<bffe-configuration>): New record type.
(bffe-configuration, bffe-configuration?,
bffe-configuration-package,
bffe-configuration-user,
bffe-configuration-group,
bffe-configuration-arguments
bffe-configuration-extra-environment-variables): New procedures.
(bffe-service-type): New variable.
* gnu/tests/guix.scm (%test-bffe): New variable.
* doc/guix.texi (Guix Services): Document the new service.
| Christopher Baines |
2022-07-15 | gnu: tests: Fix guix-data-service test....Since revision 32, guix-data-service starts immediately but returns an HTTP
error code until initialization is complete. Adjust the test accordingly, and
remove the increased startup time limit.
* gnu/services/guix.scm (guix-data-service): Use default #:pid-file-timeout.
* gnu/tests/guix.scm (guix-data-service): Retry the http-get test several
times to give the service time to initialize.
Signed-off-by: Christopher Baines <mail@cbaines.net>
| Timotej Lazar |