This avoids rumpdisk crash when booting without "noide".
Upstream status: Taken from Debian Salsa package git
https://salsa.debian.org/hurd-team/hurd/-/blob/f40ff84260b5a98bea949013415a1c92c127a43e/debian/patches/rumpdisk-no-hd
Index: hurd-debian/rumpdisk/block-rump.c
===================================================================
--- hurd-debian.orig/rumpdisk/block-rump.c
+++ hurd-debian/rumpdisk/block-rump.c
@@ -143,7 +143,6 @@ rumpdisk_device_init (void)
{
device_t device;
-#if 0
if (! device_open (device_master, D_READ, "hd0", &device)
|| ! device_open (device_master, D_READ, "hd1", &device)
|| ! device_open (device_master, D_READ, "hd3", &device)
@@ -154,7 +153,6 @@ rumpdisk_device_init (void)
disabled = 1;
return;
}
-#endif
if (! device_open (device_master, D_READ, "sd0", &device)
|| ! device_open (device_master, D_READ, "sd1", &device)
tek's customized Guix
|
Age | Commit message (Expand) | Author |
2023-04-21 | tests: Fix checks for expected failures....Addresses <https://issues.guix.gnu.org/62406>.
With 'set -e', a return status inverted with '!' does not cause the shell to
exit immediately. Instead use '&& false' to indicate an expected failure.
* tests/guix-archive.sh, tests/guix-build-branch.sh, tests/guix-build.sh,
tests/guix-daemon.sh, tests/guix-download.sh,
tests/guix-environment-container.sh, tests/guix-environment.sh,
tests/guix-gc.sh, tests/guix-git-authenticate.sh, tests/guix-graph.sh,
tests/guix-hash.sh, tests/guix-home.sh, tests/guix-pack-relocatable.sh,
tests/guix-pack.sh, tests/guix-package-aliases.sh, tests/guix-package-net.sh,
tests/guix-package.sh, tests/guix-refresh.sh, tests/guix-shell.sh,
tests/guix-style.sh, tests/guix-system.sh: Replace uses of '! ...' with
'... && false' or `test ! ...` as appropriate.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Eric Bavier |
2022-08-08 | style: Add '--whole-file' option....* guix/scripts/style.scm (format-whole-file): New procedure.
(%options, show-help): Add '--whole-file'.
(guix-style): Honor it.
* tests/guix-style.sh: New file.
* Makefile.am (SH_TESTS): Add it.
* doc/guix.texi (Invoking guix style): Document it.
| Ludovic Courtès |