Remove references to bundled mbedtls library to use the one from inputs.
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1e27d21..f0eb1a5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -85,13 +85,6 @@ endif()
set(USE_STATIC_MBEDTLS_LIBRARY ON)
set(USE_SHARED_MBEDTLS_LIBRARY OFF)
-add_subdirectory("lib/mbedtls" EXCLUDE_FROM_ALL)
-
-# Compile the mbedtls library as a static with position independent code,
-# because we need it for both a shared and static library
-set_property(TARGET mbedtls PROPERTY POSITION_INDEPENDENT_CODE ON)
-set_property(TARGET mbedcrypto PROPERTY POSITION_INDEPENDENT_CODE ON)
-set_property(TARGET mbedx509 PROPERTY POSITION_INDEPENDENT_CODE ON)
add_subdirectory(src)
change='this.form.submit();'>
build: Don't embed absolute paths in .service and .conf service files....Otherwise, users will be stuck running an old copy of guix and the guix-daemon
if they copy the service files instead of symlinking them.
* etc/guix-daemon.conf.in, etc/guix-daemon.service.in, etc/guix-publish.conf.in,
etc/guix-publish.service.in: Expand @localstatedir@ instead of @bindir@.
* nix/local.mk (etc/guix-%.service, etc/guix-%.conf): Use @localstatedir@
instead of @bindir@.
Leo Famulari
2016-11-24
Add system start-up files for "guix publish"....* .gitignore: add etc/guix-publish.conf and /etc/guix-publish.service.
* etc/guix-publish.conf.in: New file.
* etc/guix-publish.service.in: New file.
* nix/local.mk (etc/guix-%.service, etc/guix-%.conf): Generalized former
build-rules for by using patterns.
(nodist_systemdservice_DATA): Add etc/guix-publish.service, update
comment.
(nodist_upstartjob_DATA): Add etc/guix-publish.conf, update comment.
* doc/guix.texi (Invoking guix publish): Add description for enabling
"guix publish" on host distros using the new files.