Traverse the entities hash's keys in sorted order to ensure reproducibility.
--- libhubbub-0.3.3/build/make-entities.pl
+++ libhubbub-0.3.3/build/make-entities.pl
@@ -86,7 +86,7 @@
my $trie;
-foreach my $key (keys %entities) {
+foreach my $key (sort keys %entities) {
$trie = insert_node($trie, $key, $entities{$key});
}
|
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2019-01-21 | Update 'TODO'...* TODO (Installer): Add Pierre Neidhardt suggestions described here:
https://lists.gnu.org/archive/html/guix-devel/2019-01/msg00305.html
| Mathieu Othacehe |
2019-01-17 | Update 'TODO'....* TODO (Installer): New section.
| Mathieu Othacehe |
2016-09-01 | Update 'TODO'....* TODO: Remove items about guix challenge & guix publish.
Signed-off-by: Vincent Legoll <vincent.legoll@gmail.com>
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Vincent Legoll |