Traverse the entities hash's keys in sorted order to ensure reproducibility.
--- libhubbub-0.3.3/build/make-entities.pl
+++ libhubbub-0.3.3/build/make-entities.pl
@@ -86,7 +86,7 @@
my $trie;
-foreach my $key (keys %entities) {
+foreach my $key (sort keys %entities) {
$trie = insert_node($trie, $key, $entities{$key});
}
Age | Commit message (Expand) | Author |
2023-12-22 | services: Remove unnecessary references to (gnu build shepherd)....* gnu/services/databases.scm (memcached-shepherd-service): Remove
‘with-imported-modules’ form and ‘modules’ field.
* gnu/services/security-token.scm (pcscd-shepherd-service): Remove
‘with-imported-modules’ form.
* gnu/services/web.scm (hpcguix-web-shepherd-service): Likewise.
Change-Id: Ieb817508f1751e0c1ff551a0e078789a4a813c1c
| Ludovic Courtès |
ist_infoimage_DATA): Add them.
Ludovic Courtès |