These changes are commits d7e357946ead219b81cc1becbe0de8a99d96ca84 and 8ed0daa39bc662defa99507f926815431056543a in https://github.com/samtools/htscodecs. The stringtie package expects these changes to have been applied. diff -ru htslib-1.12/htscodecs/htscodecs/tokenise_name3.c stringtie-2.2.0/htslib/htscodecs/htscodecs/tokenise_name3.c --- a/htscodecs/htscodecs/tokenise_name3.c 2021-02-22 13:07:06.000000000 +0100 +++ b/htscodecs/htscodecs/tokenise_name3.c 2021-12-04 19:27:39.000000000 +0100 @@ -211,7 +211,7 @@ if (!ctx) return NULL; ctx->max_names = max_names; pthread_setspecific(tok_key, ctx); - } else if (ctx->max_names < max_names) { + } else if (ctx->max_names < max_names+1) { ctx = realloc(ctx, sizeof(*ctx) + ++max_names*sizeof(*ctx->lc)); if (!ctx) return NULL; ctx->max_names = max_names; @@ -1058,6 +1058,8 @@ tok = decode_token_type(ctx, ntok); //fprintf(stderr, "Tok %d = %d\n", ntok, tok); + ctx->lc[cnum].last_ntok = 0; + switch (tok) { case N_CHAR: if (len+1 >= name_len) return -1;/'>aboutsummaryrefslogtreecommitdiff
path: root/tests/inferior.scm
AgeCommit message (Expand)Author
2020-03-21Merge branch 'master' into core-updatesMarius Bakke
2020-03-19inferior: '&inferior-exception' includes a stack trace....Ludovic Courtès
2020-03-17tests: Fix up reference to 'guile-2.2'....Ludovic Courtès
2020-03-12inferior: Distinguish inferior exceptions....Ludovic Courtès
2019-09-21inferior: Propagate '&store-protocol-error' error conditions....Ludovic Courtès
2019-02-12inferior: Add 'inferior-available-packages'....Ludovic Courtès
2018-11-28inferior: Add 'inferior-eval-with-store'....Ludovic Courtès
2018-09-21profiles: 'packages->manifest' now accepts inferior packages....Ludovic Courtès
2018-09-21inferior: Add 'inferior-package->manifest-entry'....Ludovic Courtès
2018-09-21inferior: Add 'inferior-package-search-paths' & co....Ludovic Courtès
2018-09-21inferior: Add 'inferior-package-inputs' & co....Ludovic Courtès
2018-09-21inferior: Add 'lookup-inferior-packages'....Ludovic Courtès
2018-09-21inferior: Add 'inferior-package-derivation'....Ludovic Courtès
2018-09-04inferior: Add home-page and location package accessors....Ludovic Courtès
2018-07-13Add (guix inferior) and (guix scripts repl)....Ludovic Courtès