# Source: --- a/config_usb_printer.py +++ b/config_usb_printer.py @@ -28,6 +28,7 @@ # Std Lib import sys import os +import time # Local from base.g import * @@ -181,9 +182,10 @@ # ******************************* RUNNING FIRMWARE DOWNLOAD TO DEVICE FOR SUPPORTED PRINTER'S fw_download_req = mq.get('fw-download', False) if fw_download_req: - fw_cmd = "hp-firmware -y3 -s %s"%param + fw_cmd = "hp-firmware -n -y3 -s %s"%param log.info(fw_cmd) fw_sts, fw_out = utils.run(fw_cmd) + time.sleep(5) if fw_sts == 0: log.debug("Firmware downloaded to %s "%device_uri) else: '> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/busybox.scm
AgeCommit message (Expand)Author
2022-05-22gnu: toybox: Use #:make-flags....* gnu/packages/busybox.scm (toybox)[arguments]: Add #:make-flags to replace ad hoc use of environment variables and custom phases. Remove the 'set-environment-variables and custom 'install phase. Tobias Geerinckx-Rice
2022-05-22gnu: toybox: Update to 0.8.7....* gnu/packages/busybox.scm (toybox): Update to 0.8.7. Tobias Geerinckx-Rice
2022-05-22gnu: busybox: Update to 1.34.1....* gnu/packages/busybox.scm (busybox): Update to 1.34.1. [arguments]: Don't explicitly return #t from phases. Tobias Geerinckx-Rice
2022-01-06gnu: toybox: Use G-expressions....* gnu/packages/busybox.scm (toybox)[arguments]: Rewrite as G-expressions. Tobias Geerinckx-Rice
2022-01-06gnu: toybox: Update to 0.8.6....* gnu/packages/busybox.scm (toybox): Update to 0.8.6. Tobias Geerinckx-Rice
2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès
2021-11-30gnu: toybox: Update to 0.8.5....* gnu/packages/busybox.scm (toybox): Update to 0.8.5. [arguments]: Add a new 'fix-or-skip-broken-tests phase. Don't explicitly return #t from the other phases. Tobias Geerinckx-Rice
2021-05-04gnu: busybox: Update to 1.33.1....* gnu/packages/busybox.scm (busybox): Update to 1.33.1. [source]: Remove upstreamed patch. * gnu/packages/patches/busybox-CVE-2021-28831.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Tobias Geerinckx-Rice