This patch distinguishes between the data directory path for GUI and the one
for non-GUI by allowing to set the former path.
highlight package has two outputs: out and gui. Both outputs have files which
will be in the same directory /share/highlight/ without this patch (see also
install and install-gui tasks in makefile). In the gui's data directory,
there are GUI specific files in /share/highlight/gui-files/{l10n,ext}/.
diff --git a/src/gui-qt/main.cpp b/src/gui-qt/main.cpp
index 4700dc1..3567745 100644
--- a/src/gui-qt/main.cpp
+++ b/src/gui-qt/main.cpp
@@ -47,8 +47,8 @@ int main(int argc, char *argv[])
{
QApplication app(argc, argv);
QTranslator translator;
-#ifdef DATA_DIR
- translator.load(QString("%1/gui_files/l10n/highlight_%2").arg(DATA_DIR).arg(QLocale::system().name()));
+#ifdef GUI_DATA_DIR
+ translator.load(QString("%1/gui_files/l10n/highlight_%2").arg(GUI_DATA_DIR).arg(QLocale::system().name()));
#else
translator.load(QString("%1/gui_files/l10n/highlight_%2").arg(QDir::currentPath()).arg(QLocale::system().name()));
#endif
diff --git a/src/gui-qt/mainwindow.cpp b/src/gui-qt/mainwindow.cpp
index 3a21ad2..f060431 100644
--- a/src/gui-qt/mainwindow.cpp
+++ b/src/gui-qt/mainwindow.cpp
@@ -2131,8 +2131,8 @@ QString MainWindow::getDistFileFilterPath(){
#ifdef Q_OS_OSX
return QCoreApplication::applicationDirPath()+"/../Resources/gui_files/ext/fileopenfilter.conf";
#else
- #ifdef DATA_DIR
- return QString(DATA_DIR) + "/gui_files/ext/fileopenfilter.conf";
+ #ifdef GUI_DATA_DIR
+ return QString(GUI_DATA_DIR) + "/gui_files/ext/fileopenfilter.conf";
#else
return QDir::currentPath()+"/gui_files/ext/fileopenfilter.conf";
#endif
diff --git a/src/makefile b/src/makefile
index b1d7988..2963105 100644
--- a/src/makefile
+++ b/src/makefile
@@ -118,7 +118,7 @@ gui-qt: highlight-gui
highlight-gui: libhighlight.a ${GUI_OBJECTS}
cd gui-qt && \
- ${QMAKE} 'DEFINES+=DATA_DIR=\\\"${HL_DATA_DIR}\\\" CONFIG_DIR=\\\"${HL_CONFIG_DIR}\\\" DOC_DIR=\\\"${HL_DOC_DIR}\\\" ' && \
+ ${QMAKE} 'DEFINES+=DATA_DIR=\\\"${HL_DATA_DIR}\\\" CONFIG_DIR=\\\"${HL_CONFIG_DIR}\\\" DOC_DIR=\\\"${HL_DOC_DIR}\\\" GUI_DATA_DIR=\\\"${GUI_DATA_DIR}\\\" ' && \
$(MAKE)
$(OBJECTFILES) : makefile
ix/log/gnu/packages?id=d17eea747277643811134f9a33b534e58160688f'>packages/haskell-crypto.scm
Age | Commit message (Expand) | Author |
2023-07-23 | gnu: Add ghc-hsopenssl-x509-system....* gnu/packages/haskell-crypto.scm (ghc-hsopenssl-x509-system):
New public variable.
| Tobias Geerinckx-Rice |
2023-07-23 | gnu: Add ghc-curve25519....* gnu/packages/haskell-crypto.scm (ghc-curve25519): New public variable.
| Tobias Geerinckx-Rice |
2023-02-26 | build-system: haskell: Drop default "static" output....* guix/build-system/haskell.scm (lower): Pass outputs to lowered bag.
* guix/build/haskell-build-system.scm (install): Remove static library
moving code.
* gnu/packages/haskell-check.scm (ghc-hunit): Remove "static" output.
* gnu/packages/haskell-crypto.scm (ghc-crypto-api-tests): Likewise.
* gnu/packages/haskell-xyz.scm (ghc-case-insensitive): Likewise.
(ghc-cmdargs): Likewise.
(ghc-conduit): Likewise.
(ghc-fgl): Likewise.
(ghc-haskell-src-exts): Likewise.
(ghc-lib-parser): Likewise.
(ghc-mono-traversable): Likewise.
(ghc-parallel): Likewise.
(ghc-paths): Likewise.
(ghc-profunctors): Likewise.
(ghc-tf-random): Likewise.
(ghc-vector): Likewise.
| Lars-Dominik Braun |
2023-02-26 | Upgrade Haskell packages....Script-aided bulk change.
| Lars-Dominik Braun |
2023-02-26 | gnu: Use HACKAGE-URI for packages from Hackage....Script-aided bulk change.
| Lars-Dominik Braun |
2023-02-26 | gnu: Add upstream-name property to Haskell packages....Script-aided bulk change.
| Lars-Dominik Braun |