This patch distinguishes between the data directory path for GUI and the one for non-GUI by allowing to set the former path. highlight package has two outputs: out and gui. Both outputs have files which will be in the same directory /share/highlight/ without this patch (see also install and install-gui tasks in makefile). In the gui's data directory, there are GUI specific files in /share/highlight/gui-files/{l10n,ext}/. diff --git a/src/gui-qt/main.cpp b/src/gui-qt/main.cpp index 4700dc1..3567745 100644 --- a/src/gui-qt/main.cpp +++ b/src/gui-qt/main.cpp @@ -47,8 +47,8 @@ int main(int argc, char *argv[]) { QApplication app(argc, argv); QTranslator translator; -#ifdef DATA_DIR - translator.load(QString("%1/gui_files/l10n/highlight_%2").arg(DATA_DIR).arg(QLocale::system().name())); +#ifdef GUI_DATA_DIR + translator.load(QString("%1/gui_files/l10n/highlight_%2").arg(GUI_DATA_DIR).arg(QLocale::system().name())); #else translator.load(QString("%1/gui_files/l10n/highlight_%2").arg(QDir::currentPath()).arg(QLocale::system().name())); #endif diff --git a/src/gui-qt/mainwindow.cpp b/src/gui-qt/mainwindow.cpp index 3a21ad2..f060431 100644 --- a/src/gui-qt/mainwindow.cpp +++ b/src/gui-qt/mainwindow.cpp @@ -2131,8 +2131,8 @@ QString MainWindow::getDistFileFilterPath(){ #ifdef Q_OS_OSX return QCoreApplication::applicationDirPath()+"/../Resources/gui_files/ext/fileopenfilter.conf"; #else - #ifdef DATA_DIR - return QString(DATA_DIR) + "/gui_files/ext/fileopenfilter.conf"; + #ifdef GUI_DATA_DIR + return QString(GUI_DATA_DIR) + "/gui_files/ext/fileopenfilter.conf"; #else return QDir::currentPath()+"/gui_files/ext/fileopenfilter.conf"; #endif diff --git a/src/makefile b/src/makefile index b1d7988..2963105 100644 --- a/src/makefile +++ b/src/makefile @@ -118,7 +118,7 @@ gui-qt: highlight-gui highlight-gui: libhighlight.a ${GUI_OBJECTS} cd gui-qt && \ - ${QMAKE} 'DEFINES+=DATA_DIR=\\\"${HL_DATA_DIR}\\\" CONFIG_DIR=\\\"${HL_CONFIG_DIR}\\\" DOC_DIR=\\\"${HL_DOC_DIR}\\\" ' && \ + ${QMAKE} 'DEFINES+=DATA_DIR=\\\"${HL_DATA_DIR}\\\" CONFIG_DIR=\\\"${HL_CONFIG_DIR}\\\" DOC_DIR=\\\"${HL_DOC_DIR}\\\" GUI_DATA_DIR=\\\"${GUI_DATA_DIR}\\\" ' && \ $(MAKE) $(OBJECTFILES) : makefile >
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-09-14 00:04:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-09-14 00:04:07 +0200
commit28d1e102b671f9642ded97d467946951284c0e87 (patch)
tree8695d01589b0134781a8aaa196db9e9dd75aa597 /gnu/packages
parent4d0b8b39a7c7162a4a50b0b1ed619ef3717c35b7 (diff)
downloadguix-28d1e102b671f9642ded97d467946951284c0e87.tar.gz
guix-28d1e102b671f9642ded97d467946951284c0e87.zip
gnu: r-reticulate: Update to 1.32.0.
* gnu/packages/cran.scm (r-reticulate): Update to 1.32.0.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 98110625b8..f9f7060648 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm