Build with libtirpc on all architectures because glibc no longer provides
SunRPC support.
diff --git a/configure b/configure
--- a/configure
+++ b/configure
@@ -23635,10 +23635,13 @@
*-pc-cygwin*)
LIBS="$LIBS -ltirpc"
CPPFLAGS="$CPPFLAGS -I/usr/include/tirpc" ;;
+ *-linux-gnu)
+ LIBS="$LIBS -ltirpc"
+ CPPFLAGS="$CPPFLAGS" ;;
*) ;;
esac
-if test "X$BUILD_XDR" != "Xyes"; then
+if test "X$BUILD_XDR" = "Xyes"; then
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
@@ -23693,9 +23696,9 @@
## but we need to make sure that it is present on the system. Do that here,
## The SunRPC of the glibc has been replaced by a TI-RPC (Transport Independent RPC) library for IPv6 support
case "$host" in
- *-pc-cygwin*)
+ *)
HAVE_RPC="yes"
- ac_fn_c_check_header_mongrel "$LINENO" "rpc.h" "ac_cv_header_rpc_h" "$ac_includes_default"
+ ac_fn_c_check_header_mongrel "$LINENO" "rpc/rpc.h" "ac_cv_header_rpc_h" "$ac_includes_default"
if test "x$ac_cv_header_rpc_h" = xyes; then :
:
else
f='/guix/'>summaryrefslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2019-09-18 | doc: Add Guix Cookbook....* .gitignore: Update ignore list.
* Makefile.am (assert-no-store-file-names): Exclude the cookbook.
* bootstrap: Generate po files for cookbook translations.
* doc/guix-cookbook.texi: New file.
* doc/local.mk (info_TEXINFOS): Add it; add a rule to build cookbook
translations.
* po/doc/local.mk (DOC_COOKBOOK_PO_FILES): New variable.
(EXTRA_DIST): Add cookbook pot file and po files.
(doc-po-update-cookbook-%): New target.
(doc-pot-update): Also update cookbook pot file.
(doc-po-update): Also update cookbook po files.
| Ricardo Wurmus |
2019-04-26 | bootstrap: Break automake dependency on generated files....* bootstrap: Generate stub files for the manual translations whose
generated files are not included in the VCS.
* doc/contributing.de.texi: Remove file.
* doc/contributing.es.texi: Remove file.
* doc/contributing.fr.texi: Remove file.
* doc/contributing.zh_CN.texi: Remove file.
* doc/guix.de.texi: Remove file.
* doc/guix.es.texi: Remove file.
* doc/guix.fr.texi: Remove file.
* doc/guix.zh_CN.texi: Remove file.
* .gitignore: Add them.
Signed-off-by: Julien Lepiller <julien@lepiller.eu>
| Miguel Ángel Arruga Vivas |