Age | Commit message (Expand) | Author |
2021-05-29 | gnu: bootloader: Fix install-allwinner64-u-boot....This fixes boot breakage introduced in commit:
a65c935e29766940148d52b8116634b1e1cbcba6
Multiple files were still needed, but the filenames changed.
* gnu/bootloader/u-boot.scm (install-allwinner64-u-boot): Update to
use both SPL and u-boot files with new filenames.
| Vagrant Cascadian |
2021-02-08 | gnu: bootloader: Update install-allwinner64-u-boot....* gnu/bootloader/u-boot.scm (install-allwinner64-u-boot): Update to
use a single file to install.
| Vagrant Cascadian |
2021-02-08 | gnu: u-boot-puma-rk3399: Switch to using arm-trusted-firmware-rk3399....* gnu/packages/bootloaders.scm (u-boot-puma-rk3399)[native-inputs]:
Add arm-trusted-firmware-rk3399.
Remove arm-trusted-firmware-puma-rk3399 and rk3399-cortex-m0.
* gnu/packages/firmware.scm (arm-trusted-firmware-puma-rk3399,
rk3399-cortex-m0): Remove obsolete variables.
* gnu/bootloader/u-boot.scm (install-puma-rk3399-u-boot): Install
idbloader.img.
| Vagrant Cascadian |
2020-10-05 | bootloader: Fix u-boot installation....This is a follow-up of f19cf27c2b9ff92e2c0fd931ef7fde39c376adaa. The
bootloader installation must be done on the final disk-image, hence using
"disk-image-installer" instead of "installer" callback.
* gnu/bootloader/u-boot.scm: Turn all installer callbacks into
disk-image-installer callbacks.
* gnu/build/bootloader.scm (write-file-on-device): Open the output file with
'no-truncate and 'no-create options.
* gnu/system/image.scm (with-imported-modules*): Add (gnu build bootloader)
module.
| Mathieu Othacehe |
2020-04-20 | gnu: Add u-boot-pinebook-pro-rk3399....* gnu/packages/bootloaders (u-boot-pinebook-pro-rk3399): New variable.
* gnu/packages/patches/u-boot-DT-for-Pinebook-Pro.patch: New file.
* gnu/packages/patches/u-boot-add-boe-nv140fhmn49-display.patch: New file.
* gnu/packages/patches/u-boot-gpio-keys-binding-cons.patch: New file.
* gnu/packages/patches/u-boot-leds-common-binding-con.patch: New file.
* gnu/packages/patches/u-boot-support-Pinebook-Pro-laptop.patch: New file.
* gnu/packages/patches/u-boot-video-rockchip-fix-build.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add new patches.
* gnu/bootloader/u-boot.scm (install-pinebook-pro-rk3399-u-boot,
u-boot-pinebook-pro-rk3399-bootloader): New variable.
Co-authored-by: Jan Nieuwenhuizen <janneke@gnu.org>
| Vagrant Cascadian |
2020-02-02 | gnu: Add u-boot-cubietruck-bootloader....* gnu/bootloader/u-boot.scm (u-boot-cubietrack-bootloader): New
variable.
| Julien Lepiller |