Ill-placed #endif causes missing symbol errors when compiling without
szip. Reported to upstream maintainer.
---
src/EHapi.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/src/EHapi.c b/src/EHapi.c
index 46a9b5c..208f447 100755
--- a/src/EHapi.c
+++ b/src/EHapi.c
@@ -11379,6 +11379,7 @@ int HE5_szip_can_encode(void )
return(-1);
}
+#endif /* H5_HAVE_FILTER_SZIP */
/*----------------------------------------------------------------------------|
@@ -11509,8 +11510,6 @@ HE5_EHHEisHE5(char *filename)
}
}
-#endif /* H5_HAVE_FILTER_SZIP */
-
#ifndef __cplusplus
--
2.10.0
e='hidden' name='id' value='e5f6d0ecafba223031d8f379a91961842ca593a6'/>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2023-03-13 | gnu: rnp: Improve package style....* gnu/package/openpgp.scm (rnp)[phases]{fixes}: Rename fixes to patch-tests, use
search-input-file, and remove trailing #t.
{check}: Respect tests?.
[native-inputs]: Remove labels.
[home-page]: Update URL.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Jack Hill |
2023-03-13 | gnu: rnp: Update to 0.16.2....* gnu/packages/openpgp.scm (rnp): Update to 0.16.2.
[file-name]: Use git-file-name.
[patches]: Remove.
[arguments]: Disable downloading testing inputs in #:configure-flags.
[phases]{fixes}: Remove functionality that is no longer needed.
[native-inputs]: Replace googletest-source with googletest, remove
python2.
* gnu/packages/patches/rnp-add-version.cmake.patch,
* gnu/packages/patches/rnp-disable-ruby-rnp-tests.patch,
* gnu/packages/patches/rnp-unbundle-googletest.patch: Remove files.
* gnu/local.mk (dist_patch_DATA): Remove them.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Jack Hill |