Make shared library linking work. --- src/Makefile.in | 5 +---- 1 file changed, 1 insertion(+), 4 deletions(-) diff --git a/src/Makefile.in b/src/Makefile.in index 86880e5..24efffe 100644 --- a/src/Makefile.in +++ b/src/Makefile.in @@ -72,7 +72,7 @@ LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) \ $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \ $(AM_CFLAGS) $(CFLAGS) -DH5_USE_16_API CCLD = $(CC) -LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \ +LINK = HDF5_USE_SHLIB=yes $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \ $(AM_LDFLAGS) $(LDFLAGS) -o $@ SOURCES = $(libhe5_hdfeos_la_SOURCES) DIST_SOURCES = $(libhe5_hdfeos_la_SOURCES) @@ -124,9 +124,6 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@ INSTALL_SCRIPT = @INSTALL_SCRIPT@ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@ -# Set LDFLAGS to allow the HDF-EOS library to use extern variables from -# HDF5 -LDFLAGS = -Wl,-single_module LIBOBJS = @LIBOBJS@ LIBS = @LIBS@ LIBTOOL = @LIBTOOL@ -- 2.10.0 aboutsummaryrefslogtreecommitdiff
path: root/gnu/system/linux-initrd.scm
AgeCommit message (Expand)Author
2022-11-18linux-initrd: raw-initrd: Add keyword argument #:pre-mount....Hilton Chain
2022-03-01initrd: Use non-hyphenated kernel command-line parameter names....Maxim Cournoyer
2022-02-09Revert kernel modules changes to support the Coreboot framebuffer...Leo Famulari
2021-12-25gnu: linux-libre: Build simplefb into all x86{,_64} kernels....Tobias Geerinckx-Rice
2021-12-16gnu: linux-libre: Support the Coreboot framebuffer....Tobias Geerinckx-Rice via Guix-patches via
2021-10-13linux-initrd: Support checking NTFS volumes on boot....Tobias Geerinckx-Rice
2021-09-23linux-initrd: Support XFS....Tobias Geerinckx-Rice
2021-09-23linux-initrd: Include only the single ‘bcachefs’ binary....Tobias Geerinckx-Rice
2021-09-23gnu: Don't abuse check-btrfs-file-system to scan....Tobias Geerinckx-Rice
2021-07-08gnu: %guile-3.0-static-stripped: Rename to %guile-static-stripped....Efraim Flashner
2020-12-15store-copy: 'populate-store' can optionally deduplicate files....Ludovic Courtès
2020-12-06linux-initrd: Add bcachefs support....Tobias Geerinckx-Rice
2020-11-26mapped-devices: Add 'lvm-device-mapping'....Mikhail Tsykalov
2020-11-26mapped-devices: Allow target to be list of strings....Mikhail Tsykalov