Changes necessary for shared library linking to succeed.
diff --git a/src/Makefile.in b/src/Makefile.in
index 9534473..12411bf 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -73,7 +73,7 @@ LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) \
$(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
$(AM_CFLAGS) $(CFLAGS)
CCLD = $(CC)
-LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+LINK = HDF4_USE_SHLIB=yes $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(AM_LDFLAGS) $(LDFLAGS) -o $@
SOURCES = $(libhdfeos_la_SOURCES)
DIST_SOURCES = $(libhdfeos_la_SOURCES)
@@ -125,8 +125,6 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
-# Set LDFLAGS to alow the HDF-EOS library to use extern variables from HDF4
-LDFLAGS = -Wl,-single_module
LIBOBJS = @LIBOBJS@
LIBS = @LIBS@
LIBTOOL = @LIBTOOL@
s customized Guix
|
Age | Commit message (Expand) | Author |
2019-01-08 | gnu: readline: Update to 8.0....* gnu/packages/readline.scm (readline): Update to 8.0.
[source]: Remove patch series %patch-series-7.0.
(readline-7): New variable.
| Efraim Flashner |
2018-07-21 | gnu: readline: Update to 7.0.5....* gnu/packages/readline.scm (%patch-series-7.0): Add patch 4 and 5.
| Marius Bakke |
2018-01-19 | Merge branch 'master' into core-updates | Mark H Weaver |
2018-01-18 | gnu: rlwrap: Update to 0.43....* gnu/packages/readline.scm (rlwrap): Update to 0.43.
[source, home-page]: Use new upstream URI.
| Tobias Geerinckx-Rice |
2017-12-03 | gnu: readline: Remove obsolete post-install phase....The 'strip' phase does this unconditionally now.
* gnu/packages/readline.scm (readline)[arguments]<#:phases>: Remove.
| Marius Bakke |
2017-12-03 | gnu: readline: Update to 7.0.3....* gnu/packages/readline.scm (patch-url, readline-patch): New procedures.
(patch-series): New macro.
(%patch-series-7.0): New variable.
(readline)[version]: Include patchlevel.
[source](uri): Adjust to version suffix.
[source](patches): Add %PATCH-SERIES-7.0.
| Marius Bakke |