Changes necessary for shared library linking to succeed.
diff --git a/src/Makefile.in b/src/Makefile.in
index 9534473..12411bf 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -73,7 +73,7 @@ LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) \
$(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
$(AM_CFLAGS) $(CFLAGS)
CCLD = $(CC)
-LINK = $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+LINK = HDF4_USE_SHLIB=yes $(LIBTOOL) --mode=link --tag=CC $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(AM_LDFLAGS) $(LDFLAGS) -o $@
SOURCES = $(libhdfeos_la_SOURCES)
DIST_SOURCES = $(libhdfeos_la_SOURCES)
@@ -125,8 +125,6 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
-# Set LDFLAGS to alow the HDF-EOS library to use extern variables from HDF4
-LDFLAGS = -Wl,-single_module
LIBOBJS = @LIBOBJS@
LIBS = @LIBS@
LIBTOOL = @LIBTOOL@
ized Guix
|
Age | Commit message (Expand) | Author |
2022-06-06 | gnu: perl-term-size-perl: Remove timestamps....* gnu/packages/perl.sc (perl-term-size-perl)[arguments]: Add
'remote-timestamps phase.
| Vagrant Cascadian |
2022-06-01 | gnu: Add perl-socket-msghdr...* gnu/packages/perl.scm (perl-socket-msghdr): New variable.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Thiago Jung Bauermann |
2022-03-11 | gnu: perl-unicode-utf8: Run tests conditionally....* gnu/packages/perl.scm (perl-unicode-utf8)[arguments]<#:tests?>:
Set to #false when cross-compiling.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
| Maxime Devos |
2022-02-07 | gnu: Add perl-5.14....* gnu/packages/patches/perl-5.14-autosplit-default-time.patch,
gnu/packages/patches/perl-5.14-module-pluggable-search.patch,
gnu/packages/patches/perl-5.14-no-sys-dirs.patch: New files.
* gnu/local.mk (dist_patch_DATA): Add them.
* gnu/packages/perl.scm (perl-5.14): New variable.
| Ricardo Wurmus |
2022-02-03 | gnu: Add perl-date-range....* gnu/packages/perl.scm (perl-date-range): New variable.
| Marius Bakke |