Lookup gzdoom pk3 files in the installed directory in
addition to the path that is stored in ~/.config/gzdoom/.
Simply replacing the hardcoded /usr/share would leave the
configfile pointing to outdated guix builds, which could get
garbage collected and break the gzdoom installation.
This ensures that the files installed with the corresponding
build will be used.
--- /src/d_main.cpp 2018-01-16 22:13:09.700602781 +0200
+++ /src/d_main.cpp 2018-01-16 22:22:36.560617961 +0200
@@ -1716,6 +1716,11 @@
return wad;
}
+ mysnprintf (wad, countof(wad), "%s/%s", GUIX_OUT_PK3, file);
+ if (DirEntryExists (wad)) {
+ return wad;
+ }
+
if (GameConfig != NULL && GameConfig->SetSection ("FileSearch.Directories"))
{
const char *key;
'>koszko
build-aux: Relax the regexp used to match NEWS sections....A number of packages doesn't really make sense in the name of the section to
be substituted. This change allows using simply '*** new packages' instead of
'*** 1999 new packages', for example, and have the update-NEWS.scm script
update it.
* build-aux/update-NEWS.scm (write-packages-added) <regexp>: Do not care about
leading white space in the name of the section.
Maxim Cournoyer
2019-05-20
maint: update-NEWS: Track "gcc-toolchain", not "gcc"....This is a followup to d78010b81ee6ef4fd8803082e2f401b9e55b44db.
* build-aux/update-NEWS.scm (write-packages-updates)[important]: Replace
"gcc" by "gcc-toolchain".
Ludovic Courtès
2018-12-05
maint: update-NEWS: Don't produce full package lists....The lists of new and upgraded packages in 'NEWS' had become way too long
and redundant with what 'guix pull' reports.
* build-aux/update-NEWS.scm (write-packages-added): Don't print ADDED.
(write-packages-updates)[important, table, latest, noteworthy]: New
variables.
Print NOTEWORTHY rather than all of UPGRADED.
(main): Print PREVIOUS-VERSION and NEW-VERSION.
Ludovic Courtès
2018-09-02
Add (guix describe) and use it to initialize '%package-search-path'....* guix/describe.scm: New file.
* Makefile.am (MODULES): Add it.
* gnu/packages.scm (%default-package-module-path): New variable.
(%package-module-path): Honor 'package-path-entries'.
* build-aux/update-NEWS.scm (main): Use %DEFAULT-PACKAGE-MODULE-PATH
instead of (last (%package-module-path)).
Ludovic Courtès
2017-05-18
maint: Add 'update-NEWS' target....* build-aux/update-NEWS.scm: New file.
* Makefile.am (EXTRA_DIST): Add it.
(GUIX_MAINTENANCE_DIRECTORY): New variable.
(update-NEWS): New target.
(.PHONY): Add it.